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About This Book

HyperCard® I1GS® is a software package that lets you control
the way you use text, graphics, and sound on your Apple IIGS®
computer. This book shows you how to start using HyperCard.

The first part of the book teaches you how to install HyperCard
and explore the files that come with it. The last few chapters show
you how to create “smart” documents called szacks. Stacks can do
many of the things ordinary Apple IIGS programs can do, and
more, because you can decide for yourself how you want your stacks
to work—without knowing a word of programming,

By the time you finish this book, you'll be ready to start using
HyperCard in ways no one else may ever have imagined.




What you need to
know to use

this book

Different people
learn in
different ways

This book is for people who have never used HyperCard before.
However, the book does assume that you know how to perform
certain basic tasks with your Apple IIGS computer. You should
know how to

= Use the mouse and keyboard

s Choose commands from a menu

= Use keyboard shortcuts

» Copy files and disks

= Open disks, folders, applications, and documents

a Perform simple editing tasks, including selecting, copying, and
pasting text

s Use the directory dialog box to locate files

If you need to learn more about these basic tasks, consult the books
and disks that came with your Apple IIGs.

HyperCard comes with several books and disks designed to

make you productive quickly and help you learn the software
thoroughly. Depending on how comfortable you feel working with
the Apple IIGS, you may want to skip all the learning materials or
read every single word. Fortunately, the materials are designed to
handle the needs of a wide variety of users.
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The beginner

If you don’t yet have much experience using Apple IIGS computers,
this book was written with you in mind. As long as you know the
basic Apple 11GS skills described in the previous section, you should
do fine. Follow this plan:

= Read this book, starting with Chapter 1. The first five chapters

contain the most important information for beginners.

= You may want to skip the “Experts Only” sections at the ends of
most of the chapters.

= Explore the sample stacks.

= Ifyou have questions that aren’t answered by this book, consult

the HyperCard 1IGS Reference.

The confident rookie

If you’ve never used HyperCard before but are comfortable using
the Apple IIGS, you can zoom through this book by following this
plan:

» Browse through Chapter 1, “An Optional Introduction.”

= Speed through the installation procedures in Chapter 2, reading
just the boldface steps.

= Continue reading the rest of the chapters in this book, scanning
the introductory material, following the boldface steps, and
looking at the pictures. @

» Try the “Experts Only” sections at the ends of some of the
chapters.
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®w t0 use this book

xii

The impatient but experienced Apple IIGs user

If you're already expert in several Apple IIGS application programs
and you would prefer to learn by exploring on your own, try this
strategy:

s Play with the sample stacks. If you feel truly adventurous, set
your user level to the maximum and start dissecting the stacks.

= Ifyou need help, consult the HyperCard Tour stack (described
in Chapter 3), the HyperCard Help stack (described in
Chapter 4), and the HyperCard IIGS Reference.

You should use this book while you’re sitting in front of your

Apple I1Gs. It’s a manual for the playful.

Every chapter except the first and the last includes simple exercises
made up of numbered steps. Each step consists of a short
instruction in boldface type, followed (usually) by further
explanation in plain type. Depending on your level of expertise
with the Apple IIGS, you may find that you can speed through
some or all of the chapters by reading just the boldface steps and
looking at the pictures. Of course, you can stop and read the more
detailed explanations in plain type whenever you need to.

Most chapters end with an “Experts Only” section, which contains
experiments designed to teach you more about the techniques
you’ve learned in that chapter. The “Experts Only” section is
optional; feel free to skip it if you wish.
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Each chapter builds on what you've learned in previous chapters, so
it’s important that you start with Chapter 1 (or Chapter 2) and
work through the book sequentially:

a Chapter 1, “An Optional Introduction,” reveals the secrets of
HyperCard: what it is, what it does, and how it looks.

a Chapter 2, “Installing HyperCard,” tells you how to install
HyperCard by using the Installer program.

s Chapter 3, “Browsing Through Stacks,” introduces HyperCard
navigation techniques, showing you how to move around in the
stacks that come with HyperCard.

s Chapter 4, “More Basics,” discusses the other basic HyperCard
skills, from typing to getting help. (]

a Chapter 5, “Exploring,” shows you useful techniques for
exploring HyperCard stacks.

m Chapter 6, “Tinkering With Stacks,” shows you how stacks are
put together and how to modify them.

a Chapter 7, “Creating New Stacks,” shows you how to create
new stacks.

= Chapter 8, “Onward,” offers suggestions for further
experimentation and ideas for adding power and pizzazz to
your stacks.

s The Appendix, “Using HyperCard on a Network,” describes
special considerations for people who install HyperCard on a ﬁ'.

server instead of on their own hard disk.

Terms appear in #alics in this book when they’re first defined. These
words are also defined in the glossary.
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AbOUt the Other In addition to this book, the following learning materials are

learning materials

included in the HyperCard package:

HyperCam’ 1IGS Reference: A book you can consult to answer
questions about HyperCard as they come up.

HyperCard Tour: A stack that introduces the basic HyperCard
concepts by showing you what HyperCard can
do. (Chapter 3 of this book tells you how to use
the tour.)

HyperCard 1IGS Help: A stack that answers your questions while
(a you’re using HyperCard. (Chapter 4 of this book

shows you how to use the Help stack.)

Hyperﬂzlk Beginner’s Guide: A book that teaches you how to use
, HyperCard’s own programming language by

helping you create a new stack, one step at a time.

HyperTalk Help: A stack that provides easy access to information
o about HyperTalk® for people who use

é’ HyperCard’s programming language.
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- Chapter1

An Optional Introduction

Tlis chapter introduces HyperCard® IIGs®. For many people,
spending a few minutes now learning what HyperCard is and how
it’s used will save a lot of confusion later.

However, if you can't wait to get your hand on the mouse, you can
immediately skip to Chapter 2, “Installing HyperCard.” (If you're
already skilled with the Apple IIGS® computer and you want to go
as quickly as you can, read only the boldface, numbered steps,
starting in Chapter 2.)

/\ Important: For this chapter only, there’s no need to use your
Apple I1Gs. You'll begin to use the computer in the next chapter. &




Question: Which one of these people just discovered HyperCard?

. Curious and excited
. rim
Grim G l

Grim

Answer: The curious, excited one on the right. He’s excited because
HyperCard sounds like it can do almost anything. He’s curious
because—like most people who’ve never used HyperCard—he’s
not really sure what “almost anything” means.
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What is Hyper Card?  Most software is inspired by something outside the computer

world. For instance, painting programs were inspired by the artist’s
tools, and word processors were inspired by the typewriter. But

what about HyperCard?

11§ bl

i

7\
N/

Artist’s tools Painting program

Word processor

HyperCard
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HyperCard can do what Though you might not guess it at first, HyperCard is an electronic

index cards do  descendant of the scratch pad, the index card, and the circular
card file.

You can think of HyperCard as an electronic stack of index cards.
Every HyperCard file is called a szack, and every HyperCard stack
consists of one or more electronic cards. You use many HyperCard
stacks just as you would use stacks of index cards—to catalog a
music collection, preserve your favorite recipes, or record addresses
and phone numbers. Later you’ll learn that HyperCard stacks can
do things no one would ever dream of doing with paper index
cards—Ilike figure your taxes or control a mainframe computer.

But even when HyperCard stacks are used for the same purposes

as ordinary index cards, they can do much more than the paper
versions ever could. For example, many stacks are designed to look

like preprinted forms. In addition to allowing you to fill in the

blanks, the stacks can check to make sure you've filled in the ®
information correctly. Better yet, if the forms require some math,
HyperCard can do the calculations for you. Imagine an expense

report that figured its own totals or a recipe card that could tell you

the proportions for a triple batch of chocolate chip cookies.
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HyperCard can do
much more

8 1b. crab apples
Sugar
Water

Wash apples, remove stems and blossom tips,
) Cut apples in halves. Add water to barely
cover and cook untal soft. Crush light1y, put into a jelly bag and let
drip overnight. Next day, measure juice and boil rapidly for 2 to 3 min.
Add 3/4 cup of sugar for each cup of juice. Stir until the sugar i3
1y dissolved, then boil rapidly for 15 minutes. Remove from

2, pour into hot, sterilize

Because HyperCard is on a computer, you can make its cards

do all kinds of things that aren’t possible with real index cards.
HyperCard’s cards can contain games, calculators, and animation.
With some extra equipment, HyperCard’s cards can also control
other pieces of equipment, including other computers. For example,
you can use your Apple IIGS to control a multimedia show on a
laser disc player.
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HyperCard for the
casual and the
ambitious

Using stacks

Making your own stacks

Because people have different needs and abilities, HyperCard allows
you to use it in the manner most appropriate to your own situation.
You'll probably start using HyperCard by exploring stacks created
by other people. Then, if you like, you can learn how to make

your own.

As long as you know how to use the mouse, you can start exploring
stacks a minute after you install HyperCard. Spend an hour or

two with the first few chapters in this book and you’ll learn the
basic HyperCard skills, ranging from finding a particular card in
an enormous stack to using HyperCard’s sophisticated stack
navigation tools.

If you can't find a stack that does what you want, you can create ®
your own. The last half of this book brings you to the point where
you can create your own stacks for simple reports or catalogs. You
might think you’d need to be a programmer to create your own
stacks, but all you need is a sense of design and a few technical skills.
You can create an amazing variety of stacks by dragging components
with the mouse and using HyperCard’s Paint tools.

If you have even greater ambitions, HyperCard has still more to
offer. You can learn HyperTalk®, a programming language that
looks a lot like English, to create novel stacks of your own.

But if you don'’t like the idea of learning how to program, don't
worry—you can use HyperCard well without knowing a single Y
word of HyperTalk. This book won't require you to learn anything
about programming or HyperTalk. (However, if you do want to

learn more about HyperTalk after you've finished this book, you

can read the HyperTalk Beginners Guide.)
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You already know
a lot about HyperCard

Starts in
a typical way

Typical menu bar

Many familiar

‘ commands

Standard editing
techniques for text
and paint

Because HyperCard gives you so much flexibility—such as the
power to create your own software by creating new stacks—you
may think it’s mysterious or difficult to learn. The truth is that if
you've used the Apple I1Gs before, you already know much of what
you need to use HyperCard. Here are some of the ways HyperCard
resembles other software:

Double-clicking

HyperCardI1GS the icon opens the
program.
& File Edit
New Stack..._ B Creates new files

Open Stack... aul

Savea CODU...\\__ Opens existing

files
Page Setup..______ B Setsthe page style
Print Card @GP
Print...

Quit HyperCard @0Qf— Quits the program

Undo 74

Cut Text &X

CDDU Text aC Yog can cgt, c}?py,
Paste av and paste in the

usual manner.

Clear Text |

1
]
—

You can use the
same paint tools
available in many
other programs.

—
1
L

S{O10(0|%
RS0 N

|
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A few differences While most of the techniques you use in HyperCard will seem
familiar, some things are different:

No Save m
command

New Stack...
Open Stack.. a0
Save a Copy... HyperCard saves
your files for you
Paae Setu automatically. You
.g p... can put a copy of
Print Card aP the file away for
Print... safekeeping under
a different name
) by using the Save a
Quit HyperCard &0 Copy command. .
Alternative
method of In addition to

using the Open
command, you can
click buttons to
open files.

opening files

Windows look Windows have no

different from scroll bars or title
many other Apple —— : bars.
. I White pelicans have long beaks shaped like
[Igs windows i scoops to help them catchwriggly, slippery
i fish. They hunt cooperatively, surrounding
W fish in the water. |
When they hatch, pelicans have no feathers i ‘

i and need their parents to protect them from
I the sun.

1 In the sunmer,
i of marshes in the northern United Stutes ond
southern Canada. They spend the winter in
l u|| ‘ Mlm H - T Flondu California, and Mexico
I lf
: ;u o

(AR ‘ “ “ Wi“' I]U
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HyperCard in its
Own terms

Each card may contain
three elements:

Fields: You can type The 456-A sprocket is wsed

text in fields.

Paint: You can use
standard paint tools to
create graphics.

Buttons: You can click

buttons to make things
happen.

So far in this chapter you've learned about HyperCard by
comparing it to real-world index cards and to other programs.
Here’s a quick look at some of HyperCard’s main parts and the
terms it uses to describe them:

primarily on bicycles-specifically
on single-speed rear vheel types
of 10-speed bicycles.

This type of sprocket is
sanufactured in over 20 different
sizes for the bicycle industry.

N\ N\ N\

N\
|- AN ‘
ﬁ!& \¢, = e U
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| | s Chapter 2

[nstalling HyperCard

Before you begin using HyperCard and doing the exercises in
this book, you need to install the software.

A\ Important: If you are using HyperCard on a network, skip this
chapter and instead read the Appendix, “Using HyperCard on
a Network.” A
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What you need to run HyperCard runs only on certain Apple IIGS computers. Make sure
Hypel'CaI‘d yours has all the features listed in the figure below:

4

At least 1
800K floppy
At least
1 megabyte
of RAM.
System software

— ‘ version 5.0.3
0 Y ¥

A hard disk.

% Note: You don’t need the hard disk or the 800K disk drive if
you run HyperCard on a network. See the Appendix for more

0,

information.

If necessary, your authorized Apple dealer can help you add
memory to your computer or upgrade your system software to a
later version.

12 Chapter 2: Installing HyperCard




Inbtdlhng HypelCdld To install HyperCard on your hard disk, you need to use the
on a hard disk Installer program that’s on the HyperCard 11GS Installer and Tour
dret e disk included in the HyperCard package. The Installer program
copies the necessary files to your hard disk and places them in the

appropriate folders.

N Getting the disks ready - Before you begin, get all the necessary disks and lock them:
1. Find the six original HyperCard disks.

The disks contain the program, help files, sample files, and the

installer program. The disks are named:

HyperCard 11GS Installer and Tour
HyperCard 1IGS Program
HyperCard 1IGs Help

HyperCard 11GSs HyperTalk Help
HyperCard 11GS Stacks 1
HyperCard 1IGS Stacks 2

2. Use your thumbnail or a ballpoint pen to lock each of the
six disks.

Before you start copying files, make sure you lock your original
disks so you don’t accidentally change or delete any of the
files on them. You can experiment with greater confidence

if you know you can get your original files back from your

locked disks.

Chapter 2: Installing HyperCard 13
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You can lock the disk by sliding the plastic tab as shown in the

illustration.

When you can see /1
through the hole,
the disk is locked.

Locked Unlocked

Using the Installer  In this section you'll use the Installer program to copy the
HyperCard files to your hard disk.

Getting ready: Start up your Apple IIGs. Make sure you've installed
system software version 5.0.3 or later.

/\ Important: The Installer will not work properly and HyperCard
will not run if you don’t have system software version 5.0.3
or later. A
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1. Insert the HyperCard IIGS Installer and Tour disk.
2. Double-click the Installer icon.

i
ﬁﬁ@_— Double-click this

icon to begin the
Installer installation.

After a few moments, the Installer displays the HyperCard
Installer Script dialog box.

3. Click the Install button.

’ eIt
Disk to update: :HD
(@ HD .
Update Selection —fpplication Folder Selection =
!3 Please select the desired update ond the  ( Disk ) P tpen )
disk or folder where you want to install - '
yi2  theupdate. (tieet )i (Rews folder)

A dialog box tells you that the script installs all the HyperCard
files.

4. Click Perform This Update.
@ 5. Insert disks as requested.

After you click Install, the Installer asks you to insert each of the
HyperCard disks in turn. For each disk change, eject the old disk
by pressing the eject button on your disk drive, insert the new
disk requested by the Installer program, and then click OK.

Chapter 2: Installing HyperCard 15




6. When the Installer informs you the installation is complete,
click OK to close the dialog box.

7. Finally, click Quit to exit from the Installer program.

You may see a message warning you that some system files have
been changed and you need to restart your system. In that case,

choose the Shut Down command from the Special menu, click
Restart, and then click OK.

HyperCard is now installed on your hard disk in a folder called
HyperCard.IIGS. The folder contains the following items:

» HyperCardlIIGs, the program
» Home '
= Tour
= Help, a folder containing two help files:
o Help
HyperTalkHelp
»  Stacks, a folder containing these files:
n Addresses
o Artdeas
Birds
o Buttonldeas o
Calendar
o IconEditor
PicturePuzzler
o ScriptersTools

o StoryBoard
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Browsing Through Stacks

If you’ve already installed HyperCard according to the instructions
in Chapter 2, you're ready to get going.

By the time you're finished with this chapter, you’ll know how to
start up and quit HyperCard and how to move from stack to stack
and from card to card. In other words, you'll learn to browse

through stacks.

A Important: If you're in a hurry, try reading only the boldface,
numbered steps. The plain text below these steps contains further
explanation if you need it. &

17




| Gettlng ready The exercises in this book assume that no one has changed any of
the HyperCard files since HyperCard was installed. If you've
already made some changes and you need to keep them, rename
the HyperCard folder and then repeat the installation procedure
in Chapter 2. If you don’t need to keep your changes, you can
immediately go back to Chapter 2—the installation procedure will
automatically erase the old HyperCard folder and all of its contents.

Startlﬂg up aNd  The best way to learn HyperCard is to start using it. In this exercise
taking the tour you’ll open HyperCard and explore the HyperCard Tour.

Getting ready: If you've already installed HyperCard according
to the instructions in Chapter 2, you can start the exercise now,
beginning with step 1. If not, go back to Chapter 2 and follow the
installation instructions there.

1. Open your hard disk (if it’s not open already).
Double-click your hard disk’s icon to open it.

2. Open the HyperCard folder (if it’s not open already).

Double-click to 1
open the folder. HyperCard

(You may have to use the scroll bars to see it.)
3. Open HyperCard. ®

Open HyperCard just as you would open any program: Find its
icon and double-click it.

18 Chapter 3: Browsing Through Stacks




e —— yperlord =——=E1%
. Jitems 7473K used 13127K available
Double-click it
here to open
HyperCard116S
HyperCard. Home
Help Tour Stacks iy
(=l | ol

Once HyperCard is open, you're asked to enter your name, as
described in the next step.

4. Type your name and click the OK button.

Please enter your name: Type your name

yan here...

‘ | ...then click OK.
@) Coee)

[Andrew F. Swartz|

After you click OK, you see the first Home card, as shown in the

next step.

5. Open the HyperCard Tour by clicking its button.

Tt HEHIY
Andrew F. Swartz Jck Seebeeby
Create QuickLink...

Picture Puzzler

Click this N
button once. ; @

Copyright © 1990 Apple Computer, Inc.

[ Toolkit |[  Mttic t |

[ Basemen

The tour appears on your screen.

Chapter 3: Browsing Through Stacks
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6. Click once anywhere to start the tour.
After you click, you’ll see a short animated cartoon.
7. Click Introduction.

" Cards & Back
i :

B

Click this
button once.

click Introduction.

The introduction appears on your screen, as shown in the
next step.

8. Click the upper shadow box.

HyperCard is 8 tool kit. It has
a set of tools and an endless
supply of parts.

How you use this tool kit,
what you make or do with it,

This is a shadow
box. Click it for
more information.

As the information on the screen explains, whenever you see a
shadow box during the tour, you can click it to see additional
information. You can click the information box to hide it again.
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9. Proceed through the tour.

aurt ool ki 1A

HyperCard is a tool kit. It has
a set of tools and an endless
supply of parts.

How you use this tool kit,
what you make or do with it,
isupto youn,,‘w

........

Click the right
arrow to move
forward through
the tour.

You can leave the tour whenever you like by clicking the Go
Home button at the bottom-left corner of the screen.

10. At the end of the introduction, click the Go Home button.

If questions come up while
you're using HyperCard, you
can find quick answers in the
Help stack.

You can also refer to your
HyperCard manuals.

When you reach
this card,
click here.

If you'd like to explore more of the tour before continuing with
this book, click the What Next? button instead of clicking the
Go Home button. Whenever you’re ready to come back to the
book, click Go Home.
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Opening
HyperCard files

Opening stacks by
clicking buttons

Each HyperCard file is called a stack, and each stack contains one or
more cards. You can open stacks either by using the Open Stack
command (which is like the Open command in other programs) or,
easier still, by clicking buttons. The next two exercises show you
both techniques.

In this exercise you'll click a button to open the Birds stack and
then click another one to return to the Home stack.

Getting ready: If you're looking at the first Home card and can see
a button called Birds, you can start with step 1 now. If not, make
sure HyperCard is running, choose Home from the Go menu, then
choose First from the Go menu.

1. Click the Birds button once to open the Birds stack. ®

After you click, HyperCard closes the Home stack and opens the
Birds stack. You see the first card of the Birds stack with a picture
of a white pelican on it.
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s~

If you have problems clicking, you may not have the
<%y pointer in the correct position. Make sure the tip of
Fﬁl‘;‘g\ I‘)‘i the forefinger is over the Birds button 6o#h when you

’ click the mouse button and when you release it.

2. Without clicking the mouse button, roll the mouse around to
discover the different pointer shapes.

Don't be concerned if the pointer on your screen isn’t the shape
you think it should be. The pointer changes shape depending on

which part of the screen it’s over.

I-beam pointer. The pointer changes to this shape
when it’s over text you can edit.

—

{h-? Browse tool. The pointer changes to this shape
when it's over any part of a card (except text).

Arrow pointer. The pointer changes to this shape
when it’s over the menu bar.

>

3. Click the Home button to return to the Home stack.

The Home button is /inked to the Home stack. By clicking
the button, you close the Birds stack and open the Home
stack again.

The Home button

; jil In
o]

Card 1 of 7

In addition to learning how to use HyperCard buttons to open
stacks, you just learned an important concept: When you open a
new stack, the old one automatically closes. You can have only one
stack open at a time.
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Opening stacks by using the
Open Stack command

The Open Stack
command works
like the Open
command in many
other programs.

Double-click
“Birds” to open the
Birds stack.

24

In the last exercise you opened the Birds stack by clicking a button.
In this exercise you'll open it again, this time using the Open Stack
command. Either way, the result is the same.

1. Pull down the File menu and choose Open Stack.

Notice that the
shortcut for the
Open Stack
command is the
same as the
shortcut for the
Open command in
many other
programs.

file
New Stack...
Open Stack...
Save a Copy...

After you choose the Open Stack command, HyperCard
displays the directory dialog box, as shown in the next step.

2. Go to the Stacks folder inside the HyperCard folder.

If you have trouble finding it, click the Volumes button and
double-click the name of your hard disk. Then double-click
“HyperCard” and finally double-click “Stacks.”

3. Open the Birds stack.

Choose a stack:
=5:HD:HyperCard:Stacks:
[ Rddresses ( Volumes )
3 fArtIdeas
4 Buttonldeas — .
[ Calendar ___n!M
[ Iconkditor
[ PicturePuzzler
1 ScriptersTools

After you double-click, HyperCard closes the Home stack,
opens the Birds stack, and displays its first card, just as in the
last exercise.
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LOOking at cards  Youve learned a couple of ways to open stacks. But so far you've

seen only the first card of each stack. In this section you’ll learn how
to browse through the cards in a stack.

Getting ready: Before you start this exercise, make sure you're
viewing the Birds stack card with the white pelican on it. If you
already are, start now with step 1. If not, choose Home from the
Go menu, click the Welcome button, then click the Birds button.

1. Click the right arrow button once, and then again.

|lI.‘.u)..‘...‘m‘...‘...ul bdddila

m‘m‘n)m}aumu‘:“
{1, W 1ty
gl
! im laasassnrian dediiaand

lasini

sy

yminouu«uéui;

i E:L" il Click here twice to
? move forward two
cards.

Each time you click the right arrow button you move to the next
card in the stack. The first time you click you see the bald eagle’s
card; the second time, you move to the sandhill crane’s card.

11 cran
feathers, their backs often look brown. The
nud of their native marshes contains iron,
which stains their feathers when they preen

with muddy beaks.
. ; Migrating flocks often fly so high thet you
Notice you are o 4 c;:r: sl:: th:: without bi:oculc’s. ’
now on the third —
. Lamro il northern lands (from Siberia to central
card Of the stack E ’ 1 Conoda) ond winters in the south, from
(This stack has Eeeetleet] Colifornio through Texos to Hexico.

seven cards in it.)

2. Click the left arrow button twice to go back to the first card,
which has the white pelican on it.

Each time you click the left arrow button, you go to the
previous card.
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3. Click the left arrow button one more time.

What happens when you're already on the first card and ask to
go backward? HyperCard displays the last card in the stack—in

this case, the card for the snowy owl.

The cards in a HyperCard stack are arranged in a circular
fashion, so the first card in a stack and the last card in a stack
are next to each other.

Second card

First card

4. Click the right arrow once to return to the first card.
The white pelican’s card is displayed.

Now you know the basics of how to get around in HyperCard.
You use buttons or the Open Stack command to move from one
stack to another, and you use arrow buttons to move forward and

backward through a stack.

Knowing only that much, you can browse through almost any stack
you get. But if you learn how to use the Go menu, you'll find it
easier to move around in HyperCard.

Chapter 3: Browsing Through Stacks




USing the GO meénu  The Go menu contains commands for navigating through stacks

and moving from one stack to another. This section shows you how
to use some of the commands in the Go menu.

The basic commands  This exercise teaches you how to use the commands described in
SRS this illustration:

Goes to the last m

card you looked at. L pack &~
Returns to the __1_ Home aH
Home stack.
Help 3?
. Goes to the first Recent aR
card in the stack. ~
Goes to the previous NFirst il
card in the stack. 1 _ Prev 42
Goes to the next 1 Next 43

card in the stack.

|, Last ol
Goes to the last _/

card in the stack.

Find... GF
Message GM

Show Al11 Cards

Getting ready: If you’re already viewing the white pelican’s card in

@ the Birds stack, you can begin with step 1 immediately. Otherwise,
choose Home from the Go menu, click the Welcome button, and
click the Birds button.

1. Pull down the Go menu and choose Next.

The Next command takes you to the next card in the stack,
just as the right arrow button did in the previous exercise.
You should be viewing the bald eagle’s card, the second card
in the stack.
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2. Pull down the Go menu and choose Prev.

The Prev command, like the left arrow button, takes you to the
card in the stack immediately before the one you are looking at.
Previs short for previous. You should be viewing the white
pelican’s card again, the first card in the stack.

3. Choose Last from the Go menu.

As you might expect, the Last command takes you to the last
card of the stack you are viewing, in this case the snowy owl’s
card.

¢ Lt v
1 il i Bl

L ml”‘

#1 quietlyat night while they are hunting for
food. The edges of their wings are soft and

#1 jogged and the wings themselves are lorge,
which means the owl doesn’t have to flap thea
very much when it flies.

Owls have speci s that help them fly H

You're now

Jeving het SIS mﬂn"""wg = —
ﬂ?ﬂNﬂW&ﬁﬂlﬂVﬂﬂWﬂM e A ReIaEy

4. Choose First from the Go menu.

3 Slue showy uls lxke Snow, tlm hve uetu
E E for north, mestly in Conada and Rlaske.

\
e |“ }11

Similarly, the First command takes you to the first card of the
stack, and you see the white pelican’s card again.

5. Choose Home from the Go menu.

The Home command, like the Home button, takes you back t(.
the Home stack. Whenever you get lost, you can return Home
by choosing this command.

6. Choose Back from the Go menu.

You return to the white pelican’s card. The Back command
returns you to the last card you looked at, even if the card was in
an entirely different stack.
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The Recent command

7. Choose the Back command once again.
You go to the snowy owl’s card.

The Back command retraces your steps through the cards you
just viewed, one card at a time.

8. Finally, choose the Home command.

You may find that you want to return to a card you’ve seen recently.
To do so, use the Recent command.

1. Choose Recent from the Go menu.

HyperCard displays a dialog box showing you miniature pictures
of up to the last 18 cards you’ve seen, more or less in the order
you've seen them.

Notice, however, that even though you’ve visited the first Home
card twice, it appears only once. To be able to display as many
cards as possible in the Recent dialog box, HyperCard displays

each card only once.

2. Click a miniature picture of any of the cards from the
Birds stack.

Click any
Cards recently viewed: miniature picture
Bl ! A that looks like it
i Pk ettt came from the

Birds stack. (Your
dialog box may
look different since
you may have
looked at different
cards or seen them
in a different
order.)

3‘. AW

e P R S B
s

v 3 8 . X0
2N % ﬁ,m;' i J; :
.,s“vy LR ol it

You can go to any of the cards represented in the dialog box by
clicking its miniature.
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3. Click OK.

You go to the card whose miniature you clicked.

< Tip: Instead of clicking the miniature picture and clicking OK,
you can double-click the picture. <

QUlttlﬂg Hy’perCar d  Youleave HyperCard the same way you leave any Apple IIGS
program, by choosing the Quit command from the File menu. If
you'd like to go on with this book now, there’s no need to quit; if
you'd rather continue another time, you can quit and pick up the
book later.
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This section is for people who like learning tricks and shortcuts.
If you prefer using programs in the most straightforward way
possible, you might want to turn the page and go on to the next
chapter.

Each boldface instruction asks you to perform an experiment and
see what happens. If the result doesn't make sense, read the short
explanation in italics. If you want still more information, check the

HyperCard 1IGS Reference.

¢ Go to the Birds stack. Then try pressing the Right and Left
Arrow keys on your keyboard (as opposed to clicking the arrow
buttons on the screen).

The Right Arrow key moves you forward through the stack one card at a
time; the Left Arrow key moves you backward. You can use the arrow keys
as keyboard shortcuts for navigation.

If the arrow keys don't work, someone has turned on the Text Arrows
option on the User Preferences card of the Home stack. See the
HyperCard IIGs Reference for more details.

¢ Go to the Birds stack and press G-H.

The 3-H shortcut takes you Home. Pull down the Go menu and look at
the other shortcuts. Note that the 3 symbol refers to the Command key,
the key marked with this symbol. (In some Apple manuals, this is called
the Open Apple key,) 1o press G-H, hold down the 3 key and while it'’s
down, press the H key.
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| e Chapter 4

More Basics

Yu now know how to browse through HyperCard stacks. In this

chapter you'll learn how to do the following:
m Iype on cards
»  Add new cards
m  Save stacks
m  Use the Home stack
m  Use the Message box
» Find a card by searching for text
@ m Copy art
» Print cards and stacks

»  Get help from HyperCard
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Typlng Most stacks allow you to do much more than just look at the cards.
' For example, you can enter your own information, either by typing
or by painting. The exercises in this section show you how to type
information on cards.

If you've used an Apple IIGs word processor—or any other program
that involves typing—you already know most of what you need to
know. The main differences you’ll notice when working with text in

HyperCard are:
= You can’t use tabs to indent or line up columns.
= You can't change the text style of individual characters.

= You can’t always use the arrow keys to move through text.

Entering text  You can type text only in certain areas on a card. Each card is like a

blank form with rectangular areas where you can fill in information.
In HyperCard, each of these areas is called a field.

The Birds stack has three fields in which you can type:

AR HH‘.‘.I‘]“H‘]

Name

h lon
scoops to help them catch wriggly, slippery
fish. They hunt cooperatively, surrounding

fish in the water. J Descrip[ion
When they hatch, pelicans have no feathers .

and need their parents to protect them from l

. s he open water .
Il of marshes in the northern United States and Habitat
southern Canado. They spend the winter in I
Florida, California, and Mexico .

In this exercise you'll fill in the Habitat field for the bald eagle’s

card.

Getting ready: Before you start this exercise, make sure you're
viewing any card in the Birds stack. If not, return to the Home
stack and click the Birds button.
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1. Use the arrow buttons to find the bald eagle’s card.

Click the right or left arrow buttons to find the bald eagle’s card.
The bald eagle is on the second card.

2. To indicate where you want to type, click the upper-left corner

of the Habitat field.

ist
Uni!ed Stutes.

The largest bird’s nest ever found in North

America belonged to a bald eagle in Florida.
| The nest weighed as much as two small cars
| ond was bigger than a bathtub.

Click here.

Notice that your pointer changes to the /-beam pointer when it’s
over a field. When you click, the vertical bar that marks the
insertion point blinks at the beginning of the field.

ﬂ If you click too far down in the field, use the Delete
ﬁe:')J‘ key to get back to the top of the field. If you chck in
s Rﬁ the wrong field altogether, just try again.
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Editing text

3. Type a description of the habitat, as shown in the illustration.

You need not enter carriage returns as you type. The text will

automatically break at the right point.

"I|I|IIlllllllllIIIIllIllIlIIlllllilllllllllllllllllIlllllI|IIII|IIIIIIIIIIIIIHIIIIIIIIIIIIIIIIlllIII|IIlI|Illlll|lll|llllllllllllIIllllllllIIIII|IIIIIIIIIIIIIIIllllllllllllll

The bald eagle is an endangered species. Most

Do not press
the Return key as

- you type.

HyperCard automatically saves the text as you type it. PY

You can edit text in HyperCard fields the same way you edit

any text on your Apple IIGS. (If you don't know the standard
techniques for editing text, see the documentation that came with
your Apple IIGS.) In this exercise you'll use the standard techniques

to cut and paste some text.
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1. Select the first paragraph, including the blank line after it.

First, click here ": llllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll R

SN ONR G CR L] T |01 eagle is the national bird of the

mouse button . . . m United States. ke sucdyou
... then, drag !@m

mgil.1he largest bird’s nest ever found in North include the extra
downtohereand  “§il America belonged to a bald eagle in Florida. line between the
release the mouse ~ |. The nest weighed as much as two small cars paragraphs.)
button. and was bigger than a bathtub.

2. Choose Cut Text from the Edit menu.

The text is removed from the card and placed on the invisible
Clipboard. (Notice that the shortcut for the Cut Text command
is the same as in many other programs.)

3. Click once immediately below the remaining paragraph.

Ch KRR =K %

The largest bird’s nest ever found in North
America belonged to a bald eagle in Florida.
mmm The nest weighed as much as two small cars

, , and was bigger than a bathtub.
Click once just —|

below the paragraph.  |..

4. Choose Paste Text from the Edit menu.

The paragraph you previously cut is pasted in. (Notice that the
shortcut for the Paste Text command is the same as in many
other programs.)
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5. Insert a blank line between the two paragraphs.

The largest bird’s nest ever found in Horth
fAmerica belonged to a bald eagle in Florida.
The nest weighed as much as two small cars
Click here and_I--and was bigger than a bathtub.

, reand —The bald eagle is the national bird of the
press the Return key. United States

Addlng new cards  You can add new cards to your stack whenever you like. In this @)

exercise you'll create a new card in the Birds stack.

Getting ready: Before you begin, make sure you're still viewing
the bald eagle’s card in the Birds stack. If not, return Home,
click the Birds button, and use the arrow buttons to find the bald
eagle’s card.

1. Choose New Card from the Edit menu.

7 File |08 6o ]
----------------- Unde 42
——1  |(Bald Fagle |
Copy it The largest bird’s nest ever found in North
PasteText V] | T weavedos much s o snat ] cars.

and was bigger thon a bathtub.

S tard Ol The bald eagle is the national bird of the .

T Delec Cordh United States.
elete Car

Choose the New ___|
Card command.

Ji | The bald eagle is on endangered species. Most
'} | bald eagles now live in Rlaske.

Note that you're
currently viewing
the second card of
a seven-card stack.
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HyperCard creates a new blank card, places it after the card you
were looking at, and displays the new card:

There are now
eight cards in
the stack.

"""""""" rd 3 of 3 WWW‘
IIIIIIIIIIII|lIIIIIIIIIIHIIIIIIIIIIIIIllllmu ”'

2. Click in the upper-left corner of the Name field and type a

bird’s name:

The new card is
inserted after the
bald eagle’s card

Click here and

[hen type the [CX[. O T

3. Click in the upper-left corner of the Description field and type

a description:

] - OT T ]

) “IIIIIIIlllIIIIIIllllllIIllIIIllIIllIIIIIIIIIlmIIlllllllIIIIIIIIIIIIIlIIllI|lIIllllIIlIllllmllllllIIIIIIIIIllllIllIII|IIlllI|IIlMllllll|IIlllIIIIIIIIIIllllllllllllllllllll
Click here and 1 BhrMa1a cardinals have much brighter colors

then type the text than females. The females’ duller colors

help camouflage them when they are nesting

with the eggs.

Curdinpls have been extending_their natural
range in the last century, moving farther and
farther northward.

e

If you're not a great typist, you don’t have to type all the text.
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4. Press the Tab key on the keyboard to move to the next field.

The insertion point begins to blink in the upper-left corner of
the bottom field.

When you wish to stop typing in one field and begin typing in
another, you can use the mouse to move the insertion point
(as you did before) or you can use the Tab key (as you did

this time).

5. Type the text describing the range and habitat of the cardinal.
(Don’t press the Return key:.)

Cardinals live throughout the eastern United
States. They don’t migrate and do best where
the winters aren’t too harsh.

Your new card is complete, except that it doesn't yet have a picture
on it. (You'll add a picture of a cardinal to the card by the end of the
chapter.)

SﬂVing stacks Unlike most Apple IIGS software, HyperCard automatically saves
changes as you make them. In this exercise you'll see that there is no
Save command in the File menu. ‘
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There’s no Save
command . . .

@ he Home stack

1. Pull down the File menu but don’t choose any commands.

| New Stack...
Open Stack.. &0

| Save a Copy...——— - but you can make a

‘ duplicate copy of your file

for safekeeping with the

Page Setup... Save a Copy command.
Print Card aP
Print...
Quit HyperCard &0Q

2. Release the File menu.

Remember, you never have to save a file in HyperCard.

The Home stack will usually be your starting place when you start
up HyperCard. Take the time to get to know it. In this section
you'll learn about two important parts of the Home stack:

» The Home cards, which contain a collection of buttons that take
you to your favorite stacks.

» The User Preferences card, which you use to adjust some of
HyperCard’s settings.
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The Home cards

42

The first thing you see when you open HyperCard is the first of the
five Home cards, called the Welcome card. Each Home card is
designed to hold buttons that can quickly take you to any of your
favorite stacks. HyperCard comes with five Home cards:

Each home card
has buttons that
take you to a
different sort of
stack:

G
Andrew F. Swartz

HyperCard 1G5 |
C QuickLink

e
.| Home Stack / Welcome

b2

Help Picture Puzzler

{ Home Stack
m.&@

Story Board

& Basic stacks
Birds Tour ]

Copyright © 1990 Apple Computer, Inc.

ITIETI [ Oeskser [ voolkit ][ Mstic ][ Basement
R

Rddresses —

Office stacks

Seri
m Tool Kit Attic Bosement ‘
B e B T G o S vl
|
=

| i teon it Advanced stacks
{Cveteone [ bestser ] [RTTTCON [ itic ] [Bosement 1§
e SRR — ; These Cards are
blank, so you have
E) Welcome Deskset Tool Kit | [CTSICHNRH [ Sosement V plenty Of room to
s ————————— addyourown
{1[_Weloone Deskset ][ Tool Kit Rtic % buttons

In this exercise you'll go to the Deskset card to open the Calendar
stack. (The button for the Calendar stack isn't on the first Home
card.) Also, you’'ll learn how to rename the Home cards. The main
lesson is that this is your Home stack and you can arrange it to
please yourself.

1. Go Home. .

Choose Home from the Go menu.

2. Go to the Deskset card by clicking its button.

Click here to go to
the Deskset card.

Copyright © 1990 AppIe Computer, In
Tool Kit | [ fAttic |[ Basement

Deskset , ||

|_Veloone ]|

Chapter 4: More Basics




3. Open the Calendar stack by clicking its button.

Click here to open
the Calendar stack.

This is the Deskset — Lyome Stack / Desksel
Home card.

Andrew F. Swartz H)pelCadeIGS

[ Create QuickLik... |

gm | User Preferences |
Calendar

Addresses

[ etcons ) TSN [ ook ][ Weuie ][ Gesement ]

You can use the Calendar stack as a combination appointment
book and to-do list.

4. Return Home.
Choose Home from the Go menu.

Notice that you return to the same Home card you left from, the

Deskset card.
5. Go to the Attic Home card.

Click the Attic button at the bottom of the Home card. The
Attic and Basement Home cards are empty to give you room to
add your own buttons. You can add buttons to the other three

. Home cards as well.

You can rename the Home cards, as shown in the next steps.
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6. Click the name of the card.

Click here to
change the name
of the card.

The new name of . HyperCard I1GS |
the card appears | Create QuickLink... J§
here... | ‘

...and on the
button.

8. Return to the Home card called Welcome.

Click the Welcome button at the bottom of the card.

The User Preferences card  The User Preferences card in the Home stack allows you to choose
the user level you want to work at. HyperCard has five user levels.
When you first install it, HyperCard is set up to work at the secondf)
level: Typing. At the Typing level you can look at cards and type on
them, but you can't paint the card or modify buttons or fields.

In this exercise you'll choose the highest user level, called Scripting,
which allows you to see and use all the menus and commands

HyperCard has to offer.
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Getting ready: Before you begin, make sure you're still in the
Home stack. If you’re not, choose Home from the Go menu.

1. Click the User Preferences button on the Home card.

Click here to go to
the User Preferences card.

Hoe Stack / User Preferences

HyperCard 116§ |
Your Name: Andrew F. Swartz

Cth here, 9. Edit the scripts of buttons, fields,
cards, backgrounds, and stacks.

: 4. Create buttons and fields. Link
Authormg buttons to cords and stacks.
1o . Use the Paint tools to change the
Palntlng appearance of cards ond backgrounds.
’l‘yping X ?is:lz:?cks. Enter and edit text in ] Text Arrows

: . For clicking only. Youmay explore
Browsmg stacks but not change them.

Notice that when you move to the Scripting level HyperCard
adds two extra menus. (It also adds commands to some of the
other menus.)

HyperCard adds these two menus
when you move from the Typing level
to the Scripting level.l

| |
% File Edit Go Tools Objects
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A Important: Setting your user level to Scripting lets you use

The Message box

commands that can temporarily disable the Browse tool ().

If you find you’ve lost the Browse tool and can't type text or click
buttons, you can choose the Browse tool from the Tools menu
atany time. A&

3. Return to the first card of the Home stack.

Choose First from the Go menu. (Alternatively, you can click
the Return button on the User Preferences card.)

By changing the Preferences card in this exercise, you've gained
access to all the commands and features HyperCard has to offer.
When you're done with this book, you can come back to this card
and change your user level again if you like. ;

The Message box is a special window in HyperCard. It looks
like this:

I 0 O

It has room for one line of text in which you can type commands,
called messages, and in which HyperCard can type replies. Probably
the command you’ll enter most often in the Message box is the
Find command, which allows you to find text on a card.
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Controlling the Message box  In this exercise you'll learn how to manipulate the Message box.
In the next, you'll learn a few messages. Here’s how to display the
Message box, move it, and make it go away:

Getting ready: Make sure you're viewing the Welcome card of the
Home stack. If you aren’t, choose Home from the Go menu and
then click the Welcome button at the bottom of the card.

1. Choose Message from the Go menu.
HyperCard opens the Message box.
2. Move the Message box.

You can move the Message box by placing the pointer over the
‘ bar at the top of the box, holding down the mouse button, and

dragging it where you want it to go.

Move the Message
box here . . .

i

Tour Stou Board

941} Annlp Lamnute 1
e G

... by dragging its

nnuriaht (0}
top bar e e

3. Close the Message box by clicking its close box.

Since the close box is small, make sure you’ve got the tip of the
arrow in the box before you click.

Cth the CIOSG bOX o make IIIII|lllllllllllllllllﬂlll|IIIIIlIIIlllllllllllllllllll|I||IIlllIIIIIIIIIIIHIIIIIIlIlllIIIIIIlIlIHﬂIIIIIIIII|IIIIllllllllllmIIII||IIIIlllllllllllll"IIIIIIIllIIIIIIIIIII|Il|IIIIlIII|I|I1III|IIIl|lIlIIIIIIIIIIIIIIIIIII||||III||llIIIIIIII!IIIIIIIIllIlIIIlIIIIIIIIIIllIIIIIIIIIIllIlIIIIIII
the Message box go away. [
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Using the Message box  Now try typing some messages in the Message box. When the
Message box is visible, anything you type will be placed in the
Message box, unless the insertion point is blinking in one of the

fields on the card.
1. Go to the Birds stack.

Click the Birds button on the first Home card.
2. Open the Message box again.

Choose Message from the Go menu. Don’t worry if there’s text
in the Message box. It will disappear as soon as you start typing,.

3. Move the Message box to the bottom of the screen.

Drag the Message box by its top bar to the bottom of the screc)
s0 it’s not covering any of the buttons or text.

4. Type the words the date and then press Return.

HyperCard places today’s date in the Message box. Remember,
you have to press Return after every message. If you make a
mistake while you’re typing in the Message box, you can correct
it by using the Delete key.

I l\—— A
I The date — | /21790

return
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Finding text

5. Type 12+5 and press Return.
The date in the Message box disappears when you start typing.

You can use the Message box as a calculator. HyperCard places
the correct answer, 17, in the Message box.

_j:‘

return

6. Type flash 3
This message makes the card flash three times.
7. Type go home
HyperCard takes you back to the Home card. The Message box

automatically disappears when you return Home.
8. Type go back
HyperCard returns you to the Birds stack.

You've just learned your first words of HyperTalk. If you want
to learn more about this powerful, English-like programming

language, read the HyperTalk Beginner’s Guide.

Many HyperCard stacks contain hundreds of cards. Even so, you
can find a particular card quickly, using the Find command,
provided you remember one or two words that are typed on the
card. In this exercise you'll learn how to use the Find command.

Getting ready: Before you begin, make sure you’re viewing the
white pelican’s card in the Birds stack. If not, return Home and
click the Birds button.
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1. Choose Find from the Go menu.

HyperCard opens the Message box (if it was closed), types the
Find command, and places the insertion point between two
quotation marks. (This is exactly the same as if you typed the
command yourself. If you do type the command yourself, make
sure you include the quotation marks.)

I
| Find "'

2. Type the word crane

The word appears between the quotation marks. O

A
Find "crane"

Press the Return key.

=

As soon as you press the Return key, HyperCard searches the
Birds stack for the word “crane.” (You can find text in only one
stack at a time. HyperCard searches only the stack that’s open at
the moment you enter the Find message.)

P
(U

Sandhill I Hyper@ard finds a

Though adult sandhill cranes have gray gard Wl[h th? WOI'd ’
feihrs teir bk fen lnk o oe | “Crane” on i

ﬁégf:nzzglungetut;(esu feathers when they preen displays the Card,

Higrating flocks often fly so high that you and pUtS a box
can’t see them without binoculars. around the WOl'd.

The sandhill crane mostly breeds in cooler

"""""" = Hgupsd [ =~ | | northern lands (from Siberia to central
< Wk @ Canada) and winters in the south, from

[_tord Tof7 California through Texas to Mexico.
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4. Choose Find from the Go menu again.

If you like shortcuts, the Find command has an easy one to
remember: (S-F

I When you choose the Find command
Find "I again, it shows the last word you
looked for and highlights it.

= Open Apple key symbol: The symbol C refers to the
Command key, the key or keys on your keyboard thart are
marked with this symbol. (In some Apple manuals, this key is
called the Open Apple key.) To press (-F, press the F key
while holding down the % key. %

5. Type alaska

As soon as you start typing, the old word, “crane,” disappears.
Note that you don't have to type capital letters when you use the
Find command.

A
Find "alaska"

6. Press the Return key.

When you press the Return key, HyperCard finds the next card
in the stack with the word “Alaska” on it, in this case the tufted

‘ puffin’s card.
7. Press the Return key again.

Each time you press Return, HyperCard finds the next use of
the word “Alaska.”

8. Close the Message box.

You can either click its close box or choose Message from the Go
menu again.
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COleng and You know how to add text to cards, but that’s not all you can do.

pasting 1 piCtUI‘e You can also add art. In this exercise, you’ll copy a picture of a
cardinal from the Art Ideas stack to the cardinal’s card.

Copying the picture  Start by finding the right picture and copying it:
| 1. Go Home.
Choose Home from the Go menu.
2. Go to the Toolkit Home card.
Click the Toolkit button at the bottom of the Welcome card.

3. Go to the Art Ideas stack by clicking its button.

firt Ideus

4. Go to the People/Animals section by clicking its button.

This stack contains ¢
Art ldeas it

CoD DArrows

Click here.

5. Click the right arrow button twice to see the cardinal.
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6. Choose the Lasso tool from the Tools menu.

The Lasso tool.

The Lasso tool allows you to select an irregularly shaped object
without including any of the extra space around it.

7. Use the Lasso tool to select the picture of the cardinal.

‘ . People, Animals 3
Children, Animals

Hold down the
mouse button and
draw a line around
the cardinal with
the Lasso tool.

After you release the mouse button, the cardinal is surrounded
by a moving dashed line (sometimes called “marching ants”) to
indicate that it’s selected.

e anywhere else on
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8. Choose Copy Picture from the Edit menu.

A copy of the picture is placed on the invisible Clipboard. The
original remains on the card.

ﬁ If the art disappears from the card, you probably
<3, chose Cut Picture instead of Copy Picture. Choose

Pasting the piCtUI‘ € Now you’ll return to the Birds stack, find the cardinal’s card, and

paste the picture:

1. Go back to the Birds stack by using the Recent command.

First it1

Choose the Recent
command . . .

Cards recently viewed:

... then double-click

RIS P
[~ RN Y
ey ‘ﬂ' Julliy B Y
L;‘?ﬂh o .

any of the miniatures
in the Recent dialog

box that look like
they come from the
Birds stack.

(Your Recent dialog

box may look
different.)
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2. Find the cardinal’s card by using the Find command.

Back

Home GH
Help &?
Recent GR
First ¢l
Prev 42
Next ¢3
Last éu

Message k aH

Show A1l Cards I

First, choose the Then type ... press Return.
Find command cardinal

from the Edit and . ..

menu.

The cardinal’s card appears.

3. Choose Paste Picture from the Edit menu.

il B A I e A
il »

The picture
appears and is
selected.

Cardinals have been o
range in the last centur,
farther northward.

= w ‘ “U“ |
7 Ilh1 g

|Il H il :ll! |
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A\ Important: Be careful not to click the card outside the selected
cardinal accidentally. If you do, you'll deselect the picture and won't
be able to finish the exercise unless you use the Lasso tool to select
the bird again. A

4. Move the picture into position by dragging it.

g I

Northern Cardina i

Male cordinals have much brighter colors
than females. The females’ duller colors
help comoufloge them when they are nesting

Drag the cardinal 81 "SI ] vith the eoss.
he il Cardinals hove been extending their natural
cre. il : range in the last century, moving farther and

| farther northward.

A/l Cordinals live throughout the eastern United ‘
|| States. They don’t migrate and do best where
the winters aren’t too harsh.

5. Choose the Browse tool from the Tools menu.

The Browse tool. )
r- =)
5] &
I a | = -

It’s a good habit to choose the Browse tool after you're finished
working with other tools. Without the Browse tool, you can’t ‘
click buttons and type in fields.

Pr lﬂtlﬂg In this section you’ll learn how to print a single card or the whole
stack. HyperCard offers many printing options, including a variety
of ways to arrange the cards on the page and sophisticated methods
for generating reports. See the HyperCard 11Gs Reference for details

on these options.
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Printing one card  In this one-step exercise you’ll print the card you just pasted a
picture onto.

1. Choose Print Card from the File menu.
HyperCard prints the card.

W If you have problems printihg, consult the manuals
(S  that came with your printer and your Apple IIGs.

Ve f),l
i

O Printing a whole stack  In this exercise you’ll learn about the Print Stack command.

Getting ready: If you're viewing any card in the Birds stack, you're
ready to begin. If not, go Home and click the Birds button.

% Note: This exercise takes a while. If you're in a hurry, you might

.

want to skip it.
1. Choose Print from the File menu.
HyperCard displays a dialog box that offers a variety of options

for printing stacks, as shown in the next step.

2. Click the Print button.

. Print... (Ootions.. ) ( Cancel ) @ Click here to print
the stack.
' | Templates l

Select a template:
=P Untitled -
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Gettlng help If you have a question about how to do something in HyperCard,
you can often get the answer from the HyperCard 11Gs Help stack.
The HyperCard Help stack gives you two ways to find answers: by
looking through its list of topics or by searching for words.

Using the list of topics  Suppose you wanted to learn how to use HyperCard to print labels.
You could look through the list of topics as described in this
exercise:

1. Choose Help from the Go menu.
HyperCard opens the HyperCard I11Gs Help stack.

If you like shortcuts, Help has an easy one to remember: -2
((3—question mark). (You can also get to the Help stack by O
clicking the Help button on the first Home card.)

2. Click Printing in the list of topics.

Topics

i lick a topic ..
HyperCord Basics
Typing

Painting

Click here to

. Buttons
select the topic. Fields

Cards
Backgrounds
Stacks

Menu Reference

Apple Computer, Inc.
rved

Clicking a topic shows you a list of related subtopics from which
to choose, as you'll see in the next step.
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3. Click Printing labels in the list of subtopics.

Topics HyperCard 1165 Help

Click a topic... 2. Click o subtopic.
HyperCord Basics Printing a single card
Typing Printing a stack

Painting L, Click here to select

Printing the tex\ in specific fields . N
Buttons Printing on an Inugem?iter printer [hC 5Ubt0PK-
Fields Printing on o Laserbriter printer
Cards
Backgrounds
Stacks

Menu Reference

[Huperfalk |

The Help stack displays information about the subtopic, as
. shown in the next step.

4. Use the arrow buttons to finish reading about printing labels.

Printing labels  Printing

The text you want to print as lobels To print labels:

needs to be in background fields in g .

single background of your stack. 1. Choose Print from the File menu.
2.Click the report template that you

Before you can print labels, you have designed for your labels.
to design a printing template in 3. Click Print.
Report style specifying which
background fields contain the text To create o report template: .
you want on your labels and how you There are hve
want it printed (set the user level 1. Choose Print from the File menu. .
to Ruthoring or higher). 2. Press the shadow box labeled Céll'dS descrlbmg
Templates to view that menu. K .
3. Choose New Template from the this Sub]ect_

7 G 10f5 ww'l

Click the right
. arrow button to see
the other cards.

If you want to pursue related topics, click the See Also button.

5. Click the Topics button to return to the first card in the Help
stack.

You return to the Topics card.
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Searching for a phrase

If you’re not sure what topic to look under, you may want to use
the Search feature. For this exercise, suppose you wanted to recall

how to copy a picture in the Home stack.

Getting ready: Make sure you're viewing the Topics card in

the HyperCard I1Gs Help stack. If not, choose Help from the

Go menu.

1. Click the Search button.

. Click a topic. ..

 HyperCorg 1IGS Help

. Click a subtopic.

HyperCard Basics

Typing
Painting

Buttons
Fields
Cards
Backgrounds
Stacks

Menu Reference

Printing a single cord

Printing a stack

Printing part of a stack

Printing labels

Printing the text in specific fields
Printing on an ImogeWriter printer
Printing on a LaserWriter printer

Click here.

The Help stack displays the Search card, as shown in the

next step.

2. Type Copy picture

To search a list of related subtopics,

ISR S

Search

type your key words and press Return: Itopu picture ] When YOU type

Or click somple key words below.

7 subtopics on this list

Copy picture, it

A1l subtopics
Background buttons
Background fields
Background info
Background layer
Browse tool

Button info

Button text

Button tool
Buttons
Card buttons
Cord fields

Copying a picture
Select (Paint)
Select R11 (Paint)
Invert (Paint)
Pickup (Paint)
Keep (Paint)
Revert (Paint)

appears in this box.
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3. Press Return.

The Help stack searches for all topics related to copying pictures.
It finds seven topics and displays them in the big box below the
t box where you typed “Copy picture.”

4. Click “Copying a picture” to choose the topic.

The Help system displays information about selecting and
copying pictures.

5. Use the arrow buttons to finish reading about copying
pictures.

6. Click the Exit Help button.

& The Help stack closes and you return to whatever stack you were
looking at before you chose Help from the Go menu.
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This section contains several exercises showing you shortcuts and
more complex features. If you prefer to focus on HyperCard’s more
routine features, skip this section and go to the next chapter.

# In the Birds stack, press Tab several times. Then press
Shift-Tab several times. (Press Shift-Tab by holding down
the Shift key while pressing Tab.)

Each time you press Tab, you highlight the next field. Each time you press
Shifi-Tab, you highlight the previous field. Tab and Shift-1ab are
shortcuts for moving from one field to the next.

& While holding down the ! key, pull down the Go menu.

HyperCard displays an alternative Go menu that uses pictures instead of .

words.
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Exploring

Yu now have the technical skills you need to handle almost
any new stack you might come across. But to make the most of
HyperCard you need more than just technical skills—you need
a strategy.

This chapter teaches you a five-step strategy for exploring new
stacks:

Open a copy of the stack.
Experiment with the stack.
Find any hidden buttons.
Find all the fields.

Look for help.

You'll also learn how to get out of a stack when you want to, and
you'll explore three stacks.

03
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Practice with the
Birds stack

Open a copy of the stack

Experiment with the stack

What's this?

In this section you'll apply the five-step strategy to the Birds stack.

The first step in the strategy is to open the stack. Before you open
any stack, make sure you have a backup copy. (You already copied
all the original stacks, including the Birds stack, onto your hard disk
in Chapter 2. If anything goes wrong, you still have the original
disks as backups.) To open the Birds stack, do the following;

1. Go to the first Home card.

Choose the Home command from the Go menu and click the
Welcome button at the bottom of the card.

2. Click the Birds button. .
The Birds stack opens.

If a stack is well designed, you should be able to figure out how to
use it by trying it out. So before going any further, start clicking
buttons and typing in fields. Do whatever seems right.

For the most part, you've already done that with the Birds stack.
However, there’s still one element of the stack that you haven't tried
and that doesn’t seem to have anything to do with birds:

| White pelicans have long beaks shaped like
“ 5c00ps to help them catch wriggly, slippery |
‘! fish. They hunt cooperatively, surrounding

--p fish in the water.

il When they hatch, pelicons have no feathers
and need their parents to protect them from

| open water
[| of marshes in the northern United States and
il southern Canada. They spend the winter in

The best thing to do is try it out.
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Moving within
a stack

Moving between

stacks and programs

Utilities

Information

1. Click the light bulb button.

Clicking the button displays information about the stack. Many
of the stacks that come with HyperCard have a button with this
icon. Click it to learn more about the stack.

2. Click OK.

Here are some of the icons commonly used for standard types
of buttons:

-

Previous
Card

Go Home

About
This Stack

=

Next Card

Go Home

&

Sort

About
This Stack
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Opena Opena Opena Go Back
Stack Program Document

Show All
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Find hidden buttons  Sometimes you may fail to notice an important button. That’s why
the third step of the strategy is to look for hidden buttons.

In this exercise, you'll learn a technique for finding hidden buttons
in the Birds stack. But be careful: The author of a stack may
camouflage buttons for a good reason.

Getting ready: If you're already viewing the first card of the Birds
stack, start with step 1 now. If not, go Home, click the Welcome
button, then click the Birds button.

1. Hold down the Option and (3 keys to outline all the buttons.

A\ Important: Do 7ot click any buttons or fields while you have the
Option and (5 keys pressed. If you do, you may see a dialog box
containing the button’s or field’s script. If you do get such a dialog
box, just click its Cancel button to get rid of it. A

While the two keys are pressed, rectangles appear around the
buttons. Four of the buttons are no surprise—you’ve already
used the Home button, the light bulb button, and the two
arrow buttons; but why is the picture of the bird outlined as
if it’s a button?

White pelicans have long beaks shaped like

Il scoops to help them catchwriggly, slippery
Il fish. They hunt cooperatively, surrounding

. . i ' i a4 fish in the water. ‘
Why is the picture —_ll_ ‘:i : .
. . o T4 ! if When they hatch, pelicons have no feathers
hlghhghted asif it i Il ond need their parents to protect them from

i il the sun.
were a button? ‘

in the northern United States and
il southern Canada. They spend the winter in
it Florida, California, and Nexico,

2. Release the Option and (3 keys.
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Find the fields

3. Click the picture of the bird to see what it does.

The invisible button on top of the white pelican’s picture
plays the pelican’s call through the computer’s speaker. If you
can't hear the call, try increasing the volume setting in your
Control Panel.

All the birds in this stack, except the cardinal, have a similar
button to play the bird’s call.

You usually won't have much trouble with the fourth step of the
strategy: finding the important fields. They’re obvious in most
stacks. But you can make sure you've found them all by using

the Tab key. Try the technique with the Birds stack:
1. Press the Tab key once.
The first field is selected.

Important: Be careful not to type anything while the field is
selected, or you will erase the selected text. If you do accidentally
erase the text, you can use the Undo command to restore it. A

2. Press the Tab key several more times.

Each field is highlighted in turn—first the Name field, then the
Description field, then the Habitat field, and then the Name
field again. No surprises here: Those are the three fields you've
already typed in.

As it happens, there’s another field in the Birds stack: the one with
the card’s number in it. You’ll learn more about locked fields like
this one later in this book.
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Look for help

Emergency exits

Disappearing menu bars

Going home

The fifth and last step of the strategy invokes the old adage, “When
all else fails, read the instructions.” In short, if the stack comes with
a manual, read it. Or if it has Help buttons or menu commands,

try them.

The Birds stack doesn’t offer any way to get help except for the light
bulb button, which you’ve already used.

Sometimes you may decide you want to get out of a stack before the
stack wants to let you go. If that’s the case, here are two tricks that
you’ll find useful: making the menu bar reappear and using the
keyboard to go Home.

Some stacks hide the menu bar for aesthetic reasons. Fortunately,
it’s easy to make the menu bar appear and disappear:

1. Press( gi—Space bar.

Hold down the (5 key while pressing the Space bar. The menu
bar disappears.

2. Press (@—Space bar again.

The menu bar reappears.

If all else fails, go Home. You already know two ways of going

Home: You can click the Home button if the card has one, or you @@
can choose the Home command from the Go menu. If those

options aren’t available (or even if they are), you can always press

5-H to go Home.

1. Go to any stack besides the Home stack.
If you're on the Home card, click the Birds button.
2. Press (5-H.

Hold down the (% key while pressing H. You return Home.
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The Addr €SSES StaCk The Addresses stack is a full-featured electronic address book. In

this exercise, you'll use the five-step strategy to explore it.

Getting ready: If you already have the Home stack open, start with
step 1 now. If not, go Home.

1. Open the Addresses stack by going to the Deskset Home card
and clicking the Addresses button.

Click here to open _?2‘?
the Addresses stack.

Addresses

2. Experiment with the stack.

Here are some guesses you could make about the Addresses
stack:

Company |

These look like
Since thisisan | il ~_Adiress] ,_ buttons. Try them.
address book, the _| oy | how Rotes —
City] | Weed Click here to create

purpose of these
fields seems clear.

State| | CR
ZipCode | | 89647 i G

Telephone | | 555-0087 =

a new blank card.

Arrow buttons
usually move you

forward and
Skl Cleadr (o
M - backward through
the stack. Try them.
As you might
. guess, this button

takes you back to
the Home card.
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3. Find hidden buttons by holding down the (" and Option keys.

Are there any other buttons you haven't seen yet? Hold down
the (¢ and Option keys to see if anything surprising gets
outlined.

These labels are “Had; T

also buttons. Click _
them to see what
they do.

........ = \TE

Wm B : ‘ .

The telephone
icons are buttons
that can dial your
phone for you.

4. Find the fields by pressing Tab.
Keep pressing the Tab key until you’ve found all seven fields.
5. Look for help.

Click the light bulb icon labeled “Stack Info.” When you're
done reading, click OK.
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The Picture Puzzler

Click here to open
the stack.

The Picture Puzzler stack, as you might expect, is a HyperCard
version of a picture puzzle.

Getting ready: If you're already viewing the first Home card, start
with step 1 now. If not, go Home and click the Welcome button.

1. Open the Puzzler stack by clicking its button.

Picture Puzzler

2. Experiment with the stack.

The instructions on the first card tell you to choose an option
from the Puzzle menu. Pull down the Puzzle menu and choose
Play Puzzle.

Puzzle
Play Puzzle Try this command.
| N

Shuffie Fuzzte
Instructions

6o to Artwork Card
Modon Pazuie

Since this is a puzzle, the idea must be to put the pieces together.

Can you figure out how?

« Note: If you want to see the whole puzzle, you have to hide the
menu bar. Remember, you can hide the menu bar by pressing
—Space bar, and you can show it again by pressing ('—Space
bar again. «
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3. Find the hidden buttons.

When you hold down the (% and Option keys, each of the
puzzle pieces is outlined. As it happens, each piece is a button.
What happens when you click the buttons?

4. Find the fields.
The Tab key yields no special information. There are no fields.

5. Look for help.

You can get Help from the Puzzle menu by choosing the
Instructions command.

When you’re done reading the instructions, click OK. When
you're finished playing with the puzzle, return Home. &
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Tinkering With Stacks

Once you're comfortable exploring stacks created by other

people, you can start learning how to change old stacks and
create new ones to meet your own needs. This process is called
authoring stacks.

In this chapter you’ll enhance the Birds stack.
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TOOlS Of the tl‘éld@ To start authoring you'll need tools and commands you haven't
used before. Most of the important ones are in the Tools and
Objects menus. You'll learn about many of the specific tools and
commands later in this book.

The Tools menu is special for two reasons: It has icons rather than
words, and you can “tear it off” the menu bar and move it around
the screen, as shown in the exercise that follows.

Getting ready: If the Tools menu is visible on your menu bar, you
can begin now with step 1. If you don’t have a Tools menu, you
need to change your user level as described in “The User Preferences

Card” in Chapter 4.
1. Go to the Birds stack.

2. Tear off the Tools menu as shown here:

Pull down the Tools L
menu as if you were th
going to choosea | *13 ... but drag down
command ... [ well past the bottom
1 ofthe menu,
A A Release the mouse

button when the
palette reaches the
location you want.

When the Tools menu is torn off, it is called the Zools palette.
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3. Drag the Tools palette by its top bar to the top-left corner of
the screen.

To move the
palette, drag it by
its top bar.

= White Pelican

=4 White pelicans have long beaks shaped like

*alco ) scoops to help them catch wriggly, slippery
s A fish. They hunt cooperatively, surrounding

HlO|w fish in the water.

AlQ|Z

When they hatch, pelicans have no feathers
cad need their parents to protect them from
the sun.

In the summer, pelicans like the open water
<alignllco of marshes in the northern United States and

southern Canada. They spend the winter in
l Card 1of 8 Florida, Californig, and Mexico.

4. Close the palette by clicking its close box.

Click the close —r
box to close the
Tools palette.

| [

Since the close box is small, make sure you have the #p of the
arrow in the box before you click.
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The plan The goal of this chapter is to teach you the techniques you need to
author stacks. You'll learn these techniques by completing a set of
exercises in which you’ll tinker with the Birds stack in a variety
of ways.

White Pelican
White pelicans have long beaks shaped like
. ¢ f scoops to help them catchwriggly, slippery
5600ps to help them catchwriggly, slippery K : S fish. They hunt cooperatively, surrounding
fish. They hunt cooperatively, surrounding k g PR fish in the water.
281 fish in the water.

| White pelicans have long beaks shaped like

When they hatch, pelicons have no feathers
and need their parents to protect them from
the sun.

When they hotch, pelicans have no feathers
| and need their parents to protect thea from

| the sun.

I . p | In the summer, pelicans like the open water
| In the suamer, pelicons like the open water of marshes in the northern United States and
of marshes in the northern United Stotes and southern Conada. They spend the winter in

southern Canada. They spend the winter in Florida, California, and Mexico.

Florida, California, and Mexico.
o ol a E QMO

Before After

Preparations Before you begin, there are two things you must do: Make a new

copy of the stack so you don’t mess up the old one, and create a
button on the Home stack to take you to the copy.

Saving a COPy  Whenever you’re about to make major changes to a stack, you
should make a copy of the stack in case you make a mistake that’s
difficult to correct. You can choose whether you want to change the
original stack or the copy. (It doesn't really matter.) In this exercise
you'll create the copy, which you’ll proceed to change in the
following exercise.

Getting ready: Go to the Welcome card of the Home stack. ®
1. Go to the Birds stack.
2. Choose Save a Copy from the File menu.
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3. 'To enter the new name, type Birds.new and click Save.

Make sure <3:HD:HyperCard:
you're in the 7263 free of 20860 k.
HyperCard folder. New Folder
< HyporCord 1168
As soon as you [ Close ) Click Save after
start typing the Save copy of stackin.  {_ Save —> you've typed

new nmlm 111L*A1<>Vl§l :Bir'ds.new ] the name.

one disappears.

You now have two copies of the same file on your disk: Birds and
Birds.new. You're still looking at the original Birds stack.

. 4. Go Home.

Click the Home button o choose Home from the Go menu or
press ( %-H.

Adding a new button  To make it easier to open your new stack, you’ll create a new button
to the Home stack on the first card of the Home stack that takes you to the new stack.

Getting ready: Go to the Welcome card of the Home stack.
1. Click the Create QuickLink button on the Welcome card.

A directory dialog box appears.

Click here.

User Preferences

The Create QuickLink button on the Home cards allows you to
create new buttons that can take you to stacks.
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2. Double-click the name “Birds.new.”
The new button appears, flashing, in the middle of the card.

3. Drag the new button into position:

[ creote Quickink...]

: — 8 Dragthe new
Picture Puzzler Birds.new button here.

Tour Story Board

Copyright © 1990 Apple Computer, Inc.

rneskset Tool Kit ][ Aesic ] Basement |

If you make a mistake—either by choosing the
wrong stack or by moving the new button to an
inconvenient location—you can correct the mistake
by deletlng the button: Choose the Button tool ()
from the Tools menu; click the button once; press the
Delete key; then choose the Browse tool (). To try
again, go back and start with step 1.

4. Try the new button.

Click the new Birds.new button. Your new stack opens. @

78 Chapter 6: Tinkering With Stacks




Backgrounds

Examining a background

If you look at the pictures in “The Plan” at the beginning of this
chapter, you'll notice there are a lot of changes to make. If you had
to make those changes on each of the eight cards in the stack, it
would take a long time.

Fortunately, thanks to the HyperCard concept of background, you
only have to make the changes once. In the two exercises in this
section you'll learn more about backgrounds and how to distinguish
what’s in the background from what’s on the card.

A background contains the elements that a number of cards have
in common. This exercise illustrates the concept.

Getting ready: Make sure you’re viewing the Birds.new stack.

1. Click the right arrow button a few times to see what the
different cards have in common.

Notice that the cards in this stack have more similarities than
differences. In fact, about all that changes from card to card is
the text and the picture of the bird. The rest—the buttons, the
arrangement of the fields, and the blue paint—stays the same.

That’s the idea of a background. A background is the sum of all

the things the cards have in common.

« Note: You may notice that the colors in the background change
slightly from card to card. That’s because each card uses a
slightly different color set to make the pictures of the birds more
realistic. See Chapter 6 of the HyperCard 1IGS Reference for more

information about color sets.
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2. Choose Background from the Edit menu.

ée Go Tools Ubt _ cku — The word
W Background in the
menu bar reminds
you that you're
viewing the
background.

|Notice that there’s no text and no picture
of a bird. The text and the picture are on
the card, not the background. .

When you choose the Background command, HyperCard hides
the card and shows just the background.

3. Choose Background from the Edit menu again.

(If you prefer, you can use the keyboard shortcut (3-B.)
Choosing the command a second time lets you see the card

again. The word Background disappears from the menu bar.
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4. Choose Bkgnd Info from the Objects menu.

HyperCard displays a dialog box with information about the
background you're viewing,

Backrounds often have
names. This one is

called Bird Template.
This background is . .
@ This background contains
shared by eight cards, Phand kone: | HEAETINT | four butto%ls- Home, left
one for each of the birds. Bkand I0: 2766. Shared by 8 cards. atrow, right arrow, and the

This background Contains Y background fields. light bulb. (The button that
COHMin? f(.)ur fields.: Name, Contains Y background buttons. plays the bird’s sound is on
Description, Habitat, and [Jcan't Delete the card layer, not the
. Card Number. CT0on't Search background layer.)

(Seript..) (Colors.) ok ) (conceld Click here to close
the Info box.

5. Click Cancel.

An experiment: To give you a better understanding of the difference between a card
cards versus backgrounds and a background, these two exercises have you spray-paint a spot
on the card and then in the background.

Spray-painting a card

In this exercise you'll spray-paint a card and discover that the

& change is visible on that card only.
Getting ready: Make sure you’re viewing the Birds.new stack.
1. Go to the first card.
Choose First from the Go menu.

2. Choose the Spray tool () from the Tools menu.
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3. Carefully spray-paint a small area as shown in the figure.

/\ Important: Don't paint too close to the picture of the bird, because
that’ll make it hard to erase the spray paint. &

White nelxcuns huve lono beuks shoned hke
scoops to help them catchwriggly, slippery
fish. They hunt cooperatively, surrounding
fish in the woter.

13: When they hatch, pelicans have no feathers

Carefu lly Spl"dy-pﬂi nt i .‘i“ | :R: 2;:«! their parents to protect them from
here by holding 1 .
down the mouse ==y o wishes it orther i Staes and
button and moving  iEaeli l ot ot st wesieo

the mouse.

4. Choose the Browse tool (¥2) from the Tools menu.

If you like shortcuts, you can press (3-Tab whenever you want to
select the Browse tool.

5. Look at the next card and then return to the first card.

Click the right arrow and then the left arrow. Notice that the
spray paint appears only on the card on which you painted it.

6. Choose the Eraser tool (&) from the Tools menu.

7. Erase your spray paint.

'.'Jhlte Pellcu . .

White pelicans have long benks shuped hke
scoops to help them catchwriggly, slippery
ish. They hunt cooperatively, surrounding
ish in the water.

| i ia ) The Braser ool
erases any paint
e g el e gy [ unclerneath the
| southern Canado. They spend the winter in | pointer as long as
™ Tordtof§ ] Florid, Cnhfornn, and Nexico. - the mouse button

is down.
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Spray-painting a background

Now you’ll make the same mark in the background and discover
that the change is visible on every card.

1. Choose Background from the Edit menu.

The Background command hides the card’s text and allows you
to edit the background. It also displays the word Background in

the menu bar.
2. Spray-paint the same place as before.

Choose the Spray tool (') from the Tools menu again and paint
inside the frame where the bird pictures go.

A Warning: Be careful to spray-paint only in this area. If you
accidentally get paint anywhere else, immediately choose Undo
from the Edit menu. Otherwise, you’ll find it hard to erase
the paint. A

3. Choose Background from the Edit menu.
The word Background disappears from the menu bar.

4. Choose the Browse tool () from the Tools menu and look at
the next few cards.

Click the right arrow a few times. Note that by painting the
background rather than the card, your change affects all the
cards.

5. Being careful not to erase the bird, choose the Eraser tool (&)
from the Tools menu and try to erase your spray paint. (You
won’t be able to erase it.)

Because the paint is in the background rather than on the card,
you must choose the Background command before you can
erase it.
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6. Choose Background from the Edit menu.
The word Background appears in the menu bar.
7. Erase your spray paint.

Now you can erase the spray paint. But be careful not to erase
any of the other paint in the background. If you do accidentally
erase something other than your spray paint, immediately
choose Undo from the Edit menu.

8. Choose the Browse tool () from the Tools menu again.

You need the Browse tool to click buttons and type text.
Choosing the Browse tool also takes you out of the
background—the word Background disappears from the

menu bar.

Summary: card layer versus  In short, what you see when you look at a card is a composite of
background layer  two layers: the background layer (which contains the elements shared
by all the cards) and the foreground or card layer (which contains
only the elements unique to each card).
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Tinkering With  There’s no special order in which you have to make changes. For

bUttOHS the sake of convenience, the exercises that follow start with the
" changes to buttons.

Before you begin, you might want to look at the section called “The
Plan” at the beginning of this chapter to see all the changes that you
need to make.

Deleting the light = You'll start by deleting the light bulb button. In general, the way
bulb button you delete things on the Apple IIGS is *o select them and then press
the Delete key. The same is true for deleting HyperCard buttons.

Getting ready: Make sure you're viewing the Birds.new stack.

. 1. Choose the Button tool (<) from the Tools menu.

To modify buttons, you must use the Button tool. While you
use the Button tool, the pointer will be arrow-shaped and you
won't be able to type in fields or make buttons do what they’re
programmed to do.

2. Click the light bulb button once to select it.

When a button is selected, it’s framed by a moving dashed line,
sometimes called “marching ants.”

Notice that the button doesn’t do what it normally does—it
doesn’t give you an overview of the stack. Instead, clicking a
button with the Button tool selects it.

® 3. Press the Delete key.
The button disappears.

< A good question: Since this button was in the background, why
didn’t you first have to choose the Background command to
delete it? You could do just that, but as a shortcut, HyperCard
allows you to edit existing buttons and fields without first
choosing the Background command.
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Moving the buttons Next you’ll move the Home button and the two arrow buttons.
(You'll also take a look at some instructions written in the

HyperTalk script language.)

Getting ready: Make sure you’re viewing the Birds.new stack and
using the Button tool (=) from the Tools menu.

1. Drag the right arrow button to its new location.

ﬁ Hhm nehcans hnve lons beaks shoned lxke
| scoops to help them catchwriggly, slippery

ish. They hunt cooperatively, surrounding
ish in the water. k ,
hen they hatch, pelicans hove no feathers  fi Make sure youre
‘Rd need their porents to protect them from using the Button
e sun.
—————————ell (00l then place the
n the summer, pelicans like the open water ointer over the
of l‘nhrshez in ;he ?:rthern gntiﬁed St:!eg and p
| southern Canada. They spend the winter in : y
CurdlofB 11 Florido, California, and Mexico. | mlddle Of [he bU[[Oﬂ
‘ - ‘ and drag it here.

2. Drag the Home button and the left arrow button to their new
locations.

Remember to drag the buttons by their middles.

Htuu pehcuns have lona beaks shuped like

| scoops to help them catchwriggly, slippery
ish. They hunt cooperatively, surrounding
ish in the water.

hen they hatch, pelicans have no feathers i
:d need their parents to protect them from  fi .
e sun.

n the summer, pelicans like the open water
Il of marshes in the northern United States and ||
il southern Canada. They spend the winter in j Place the

- Cord 0 Florida, California, and cho y

buttons here.
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3. Click the Home button once to select it.

4. Choose Button Info from the Objects menu.
A dialog box opens.

5. Click the Script button in the dialog box.

Buttons usually have scripts that tell them what to do when
they’re clicked. You don’t have to know anything about scripts,
but here’s one for the sake of curiosity:

Script of Bkgnd button ID 9 = "Home"
on mouselp s
The script says that | visual effect iris close ]
. go home
when the button is end mouselp
. clicked, HyperCard
should open the
Home stack using a
special visual effect.
After you're
finished looking,
Iy click the _
(CanceTy Cancel button.

6. Click the Cancel button to close the script.

Rearranging the Now you’ll change the appearance of all three buttons by changing
‘ arrow buttons  their style from Shadow to Transparent.

Getting ready: Make sure you’re viewing the Birds.new stack and
using the Button tool (=).

1. Double-click the left arrow button to open its Info dialog box.

Double-clicking a button with the Button tool is a shortcut for
selecting it and choosing the Button Info command.
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Hold the mouse
button down over the
word “shadow” . . .

Adding a button linked to
the Calendar stack

88

2. Use the pop-up Style menu to change the style from shadow
to transparent.

... then drag up
Butten hene: (HER opaque to select the word
Bkgnd button number: 2 Bkgnd i rectangle “transparent.”
[C] Show Name Style: | shadow
B Auto Hilite Feail round rect
amiiy:
[ Share Hilite ¥ | check box
radio button

(Link To..) ( Font... )
[Script...) [Colors...] |! 0K I] lCuncell

4. Similarly, open the Home button’s Info dialog box, set its style
to transparent, and then click OK.

3. Click OK.

5. Repeat the process a third time with the right arrow button.

Open the right arrow button’s Info dialog box, set its style to
transparent, and click OK.

Next you’ll add a button that can take you to the Calendar stack so
you can quickly enter appointments to go birdwatching.

Creating the button &
Start by creating the button and specifying its appearance.
1. Choose New Button from the Objects menu.
HyperCard places the button in the middle of the card.
2. Double-click the button to open its Info dialog box.
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3. Set the button’s attributes as follows:

Type Calendar to N
name the button. Button Name: i
¢ transparent - Use this pop-up
Click 1 o Card button number: 2 Card bu opague menu to choose the
¢ ;feiﬁ (;hum (1 Show Name Style: | rectangle transparent style.
sz fe i ow Auto Hilite Family: shadow
¢ feature. [ Share Bilive | roundrect
check box
radio button
(Link To..) ( Font... )
[Script...] [Colors...] ﬂ 0K D ( Cancel )
. 4. Click the Icon button.

5. Select the Calendar icon and click OK.

Use the scroll bar
to find the
Calendar icon.

Click the icon to
selectit. ..

... then click OK.

The icon appears partially clipped off inside the new button.
6. Click OK again.
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7. Move the button into place and resize it.

You can move the button by dragging its middle. You can
change the size of the button by dragging any one of its corners.

ite pelicans have long beaks shaped like
| scoops to help them catchwriggly, slippery
| fish. They hunt cooperatively, surrounding
o4l fishin the water.

il When they hatch, pelicans have no feathers
| and need their parents to protect them from
| the sun.

In the summer, pelicans like the open water
of marshes in the northern United States and
southern Canada. They spend the winter in

Move the button to ‘
here and adjust its size.

It’s OK if the button overlaps the bottom field a little. You'll
fix that by the end of the chapter.

Creating the link

So far, you have a beautiful button that doesn’t do anything.
By creating a link you’ll make the button work.

Getting ready: Make sure you still have the Button tool (=)
selected.

1. Double-click the new button to open its Info dialog box. ‘
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Click here.

2. Click the Link To button.

When you click the Link To button, HyperCard needs to know
which card or stack you wish to make the link to. To let you

know it’s waiting for you to complete the action, it displays the
Link To box:

R 0 000 R

Link to:
(This Cord ) (This Stack) ( Concel )

You specify that you want a link to the Calendar stack by
opening the Calendar stack, as described in the next steps.

3. Go to the Deskset card in the Home stack.

Choose Home from the Go menu and click the Deskset button.
(You can click buttons even though the Link To box is displayed.

If it’s ever in the way, you can move it by dragging its top bar.)

4. Click the Calendar button to open the stack.
5. Click “This Stack” to complete the link.

Link to:

This Cord N 0 m oty Addresses  Home

J
P UL B LAY
2B N[B]% 7 B Tuesday, July 31, 1990
29 30 31

[<]  ugooo >}

Things To Do

You return to the Birds.new stack.
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Testing the button

In this exercise you’ll test the button and discover that you placed
the button on the card instead of in the background. In the next
exercise you'll correct the mistake.

1. Choose the Browse tool () from the Tools menu.

2. Click the new button to test it.
The Birds.new stack should close and the Calendar stack should

open.

If the button did 7oz work correctly, return to the
Birds.new stack, choose the Button tool (=), click
_your button once, and press the Delete key. Then

T“C‘alendar Stéick”) aga1 Lo

3. Choose Back from the Go menu until you return to the
Birds.new stack.

You may have to choose the Back command twice.

4. Go to the next card by clicking the right arrow button.

Whoops! If you followed the directions in the previous section,
you’ve discovered that your new button isn’t on the next card.
Why? You created the button on the card instead of in the

background.

That’s one of the most common mistakes stack authors make.
The next exercise will show you how to correct it.

5. Go back to the card with the Calendar button on it.

Click the left arrow button.

Chapter 6: Tinkering With Stacks




@ Copying the Find button

Moving the button from the card to the background

'To move the button from the card to the background, you need to
select the button, cut it, go to the background, and paste it.

1. Choose the Button tool (=) from the Tools menu.
2. Click the Calendar button to select it.
3. Choose Cut Button from the Edit menu.
The button disappears.
4. Choose Background from the Edit menu.
5. Choose Paste Button from the Edit menu.
6. Choose the Browse tool () from the Tools menu.
You leave the background and the word Background disappears

from the menu bar.
7. Go to the next card to make sure it worked.
The button now appears on all the cards.

Because creating objects on the card instead of the background (or
vice versa) is one of the most common mistakes stack authors make,
you might want to fold down the corner of this page so you can
find these instructions easily. Remember this strategy to correct the
mistake: select, cut, background, paste.

One easy way to enhance your stack is to borrow work done by
others. In this section you'll add a button by copying it from the
Button Ideas stack. The new button will automatically choose the
Find command.
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Copying the button
Start by finding and copying the button.
1. Choose the Browse tool () from the Tools menu.
2. Go Home.
3. Go to the Tool Kit card.

Click the Tool Kit button at the bottom of the card.
4. Click Button Ideas.

The Button Ideas stack contains buttons you can use in your
stack.

5. Click Help and Information to get to the card with the Find @@

button on it.
6. Choose the Button tool (=) from the Tools menu.

7. Click the Find button once to select it.

Click here once
toselectthe £
Find button. i

8. Choose Copy Button from the Edit menu.

Be careful to select the Copy Button command and 7ot the Cut
Button command. .
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Pasting the button

Now return to the Birds.new stack, paste the button, and move it
into place.

1. Use the Back command to return to the Birds.new stack.

Keep choosing the Back command from the Go menu until you
return to the Birds.new stack. (You will probably need to choose
the Back command four times.)

2. Choose Background from the Edit menu.
Make sure you see the word Background in the menu bar.

Since this button should be shared by all the cards in the stack,
® you should paste it in the background.

3. Choose Paste Button from the Edit menu.
The button appears in the background.
4. Double-click the button to open its Info dialog box.

5. Change the style to shadow, then click OK.

Use the pop-up Style menu to change the style and then
click OK.
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Move the button
here and
adjust its size.

Tinkering with fields

Deleting the card
number field

6. Move the button into place and resize it.

ite pelicons have long beaks shaped like ||
Il scoops to help them catch wriggly, slippery |
| fish. They hunt cooperatively, surrounding
“ fish in the water.
\‘ When they hatch, pelicans have no feathers
I ttl;:d need their porents to protect them from  §
il the sun.

| Inthe sunmer, pelicans like the open water
i of marshes in the northern United § d

il southern Canada. They spend the wi
i|_Florida, Californi, 0 0.

7. Choose the Browse tool () from the Tools menu to see how it

all looks. O
You leave the background layer, and the word Background

disappears from the menu bar.

Now that you have the buttons pretty much as they should be; it’s
time to start on the fields. Once again, you might want to go back

and look at the section called “The Plan” at the beginning of the
chapter to see the changes that you need to make.

The plan doesn’t call for a Card Number field, so you'll delete it
in this exercise. Deleting HyperCard fields is similar to deleting
HyperCard buttons and other objects in Apple IIGS programs. Yo
select the object and then press the Delete key.

Getting ready: Make sure you're in the Birds.new stack.
1. Choose the Field tool (£2) from the Tools menu.
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2. Click the Card Number field once.

1 Whise i mb ve. lPﬂI‘M ilike.
-pfﬁs .E.;}lz.;omm v: ‘s'hrmzd""

Eeh e Tigans Nave fo teqthers " |
811 porents to protect them fron”

Click here onceto
select the field.

As a shortcut, HyperCard allows you to select and manipulate
@ background fields even when you’re not in the background.

3. Press the Delete key.

When you delete a background field, you also delete all the

text typed into it for every card in the stack that shares the same
background. Because deleting a background field by mistake can
be a catastrophe, HyperCard asks if you're sure.

A Warning: Make sure you've selected the right field before you

delete it. You cannot undo the deletion. a

4. Click Delete to confirm your decision.

MOdifying the bird In this exercise you’ll change the font, style, and color of the bird
name field name field.

Getting ready: Make sure you're still in the Birds.new stack and
that you still have the Field tool (&) selected.
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1. Double-click the Bird Name field at the top of the card to
open its Info dialog box.

This is the same as selecting the field and choosing Field Info
from the Objects menu.

2. Click the Font button.
The Text Style dialog box appears.

3. Set the attributes as described below:

"""""" Style: — Courier @ :: Finally, click OK.
% ?:l?w Geneva L L )
[Junderline g;lvetlcu .
Click Venice. =P m:::"" Double-click here ‘
[ Shadow THT: ] and type 14.

i),
Use the pop-up AlignLeft | Line Height: [14_ | Font Size:

menu to choose

Center Text
CenterText. || [¥atign hight I fox jumps over the lazy dog.

4. Click the Colors button.
5. Set the text to be purple, then click OK.

[The quick (EMTEGE tokes o running Leap
aver the lazy dog.

Click this color. ‘

Frame

i
tlH M
(i

i) -

Then click OK.
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6. Click OK one more time.
The Bird Name field should now look like this:

'Moving the fields closer Since there’s not quite enough room at the bottom for the row of
together  buttons, you'll move the fields a little closer together in this exercise.

Getting ready: Make sure you’re still in the Birds.new stack and
that you still have the Field tool (E2) selected.

1. Make the Bird Name field a little smaller by dragging its

corner.

e
White Pelican

pill__ While holding
R e e P E et 45wy thee Sife key,
White pelicans have long beaks shaped like drag this corner of
scoops to help them catchwriggly, slippery the field up until
f1sh. They hunt cooperatively, surrounding the field is this size.

Holding down the Shift key allows you to adjust the field’s
height without changing its width (and vice versa).
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While holding
down the Shift key,

drag the middle of

the field up until

the field is here. .

Holding down the Shift key allows you to move the field up and

down without moving it sideways (and vice versa).

Remember the general rule that, on the Apple IIGS, to move
something you drag its middle; to change its shape you drag its
corner: middle to move and corner to change.
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3. Drag the Habitat field up in the same way.

IS

‘ & ;ﬂv{vhmmns hgye no teathers
| m

their agrents soratest thenfron . B While holding

{|  down the Shift key,
drag the middle of
the field up until
the field is here.

Creating the Notes field The plan for the Birds.new stack calls for a field in which you can
O type your own notes. In the next two exercises, you'll create the field
and test it by filling in some notes.

Creating the field
In this exercise you'll create the field.

1. Choose Background from the Edit menu.

To put the Notes field on all the cards, you must create it in the
background. You can confirm you’re working in the background

by looking for the word Background in the menu bar.
2. Choose New Field from the Objects menu.
o HyperCard places a new field in the middle of the window.
Double-click the new field to open its Info dialog box.
Use the pop-up Style menu to set the style to scrolling.
Type Notes to name the field.
Click OK.

A A
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7. Resize the field and move it into position.

aks shaped like
1 1_3

Change the
field’s size and
move it here.

The field should be as wide as the bird’s picture frame and just
tall enough to fit three lines of text. @

Using the field
In this exercise you'll type some dates in your new field to test it.
1. Choose the Browse tool (¥) from the Tools menu.

The word Background disappears from the menu bar.
2. Choose First from the Go menu.

You return to the white pelican’s card, the first in the stack.
3. Click once in your new field.

The insertion point begins to blink.

4, Type the following: The pelican reminds me of a
stork. You can almost picture a sling hanging
out of its mouth and a baby hanging out of the

sling.

Notice that the field automatically scrolls. You can use the scroll
arrows to move back and forth through the text.
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5. Move to the next card.

Click the right arrow.
6. Click your new field.

7.]ypa I sighted a bald eagle near Seattle on
April 26, 1990.

Cr eating the label for the According to the plan, the word “Notes” should be above the Notes
Notes field  field. When you need to put text on the background, you have two
choices: you can either paint it or use a shared-text field. (See
Chapter 5 of the HyperCard IIGS Reference for details on the
considerations involved in the choice.) In this case youll make the

. label a shared-text field.

Duplicating a field

Instead of creating the field from scratch, you’ll make a duplicate of
the Notes field and modify the duplicate as necessary.

1. Choose the Field tool () from the Tools menu.

2. Press and hold the Option and Shift keys while you drag the
field up.

While holding

down the Option

and Shift keys, drag

‘ the Notes field by
its middle and place

the resulting new

field here.

Dragging the field while you hold down the Option key creates
an exact duplicate of the field. Dragging the field while you hold
down the Shift key restricts the movement of the field to either
straight up and down or straight left and right. Dragging the
field while you hold down both keys produces both effects.
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A Important: Be careful not to duplicate the field more than once.
Every time you click the field while the Option key is pressed
you create another field, so every false start creates an extra field.
Delete any extra fields by selecting them and then pressing the
Delete key. A

3. Double-click the new field to open its Info box.
4. Type Notes Label to name the field.
5. Click Shared Text.
When you click Shared Text, the Don’t Search check box is

automatically selected as well.

6. Use the pop-up Style menu to change the style from scrollinfff)

to transparent.
7. Click Font.

8. Click Bold and then click OK in the Text Style box and again
in the Info box.

9. Adjust the size of the Notes Label field:

"""" While holding
mll IN“ Ul <aut down the Shift key,

I
IMM | ari__ drag this corner up

i e
oot @
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Putting the text in a shared-text field

You edit text in a shared-text field just as you edit text in other
fields. However, since you don’t want anyone to change the text, it’s
a good idea to lock it.

Getting ready: Make sure you're viewing the Birds.new stack.

1. Choose the Browse tool ().

You need the Browse tool to type in the field.

2. Click once in the new field.

. Click once here.

i
The pelican reminds me of a
stork. You can almost
picture a sling hanging out

The insertion point will blink in the new shared-text field and
the field will turn white while you’re typing in it.

Type Notes

Choose the Field tool (&3) from the Tools menu.
Double-click the new field to display its Info box.
Click the Lock Text box and click OK.

AN S

An X in the Lock Text box indicates the option is selected.
7. Choose the Browse tool (¥) from the Tools menu.
8. Look at a few cards to make sure the text is in fact shared.

Click the left and right arrow buttons to move forward and

back.
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FlﬂlShlng tOUChGS You're finished with the important changes to the stack. Now it’s

time for a few final adjustments to make the stack look better. You’ll
perform three tasks: Arranging the buttons a little more precisely;
drawing a decorative box around the three transparent buttons; and
flipping the cardinal to make it look better.

Getting ready: Make sure you're viewing the Birds.new stack.
1. Choose the Button tool ().
2. Arrange the buttons.

Now that you have more room, move the buttons like this:

Move these twol | Move these buttons

buttons up a little. to the center, leaving
plenty of room for
the frame you are
about to draw.

3. Choose the Background command from the Edit menu. ‘

The word Background appears in the menu bar.
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4. Choose the Rectangle tool ((J) from the Tools menu and draw
a rectangle like this:

I
’llllu Il ||||mn||m Illlllﬂ Il
Starting here, hold

down the mouse
button . . .

.. and drag here.

If you make a mistake, choose Undo from the Edit menu before
trylng again.
5. Choose the Paint Bucket (&) from the Tools menu.

6. Choose a color or pattern from the Patterns menu.

For example, you could choose white to match the other two
buttons on the same row:

Patterns
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7. Pour paint into your rectzmgle.

REESIE

Remember, you can use the Undo command if you make a
mistake.

8. Choose the Browse tool ().

Click anywhere

inside the rectangle. um

You automatically leave the background and the word

Background disappears from the menu bar.
9. Find the cardinal’s card.

Use either the Find command or the arrow buttons to find the
cardinal.

10. Choose the Selection tool (:_3) from the Tools menu and select

the cardinal like this:
Starting here, hold g e
down the mouse il Nurtlwl 1l I."ardmat
f Male cardinals h h brighter col
button... 4 | oo Fenales,The fomaios: duller oolors help K

camouflage them when they are nesting with
the eggs.

Cardinals have been extending their natural
range in the last century, moving forther and

‘ farther northward.

Cardinals live throughout the eastern United l 3
States. They don’t migrate and do best where i

.and drag here, __ the winters aren’t too harsh,

11. Choose Flip Horizontal from the Paint menu to flip
the bird.

12. Choose the Browse tool () again.
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EXP@ITS@ Only This section describes several shortcuts. If you'd prefer to move on

to the next exercises, start the next chapter.

# In the Birds stack, hold down the Option and C keys and
while they’re still pressed, click any button.

HyperCard displays the buttons script. Click the Cancel button to close
the script.

¢ Tear off the Tools menu and choose the Browse tool (). Hold
down the (% key and press Tab twice quickly. Then try holding
down the (¥ key and pressing Tab three times.

‘ Pressing C3-Tab twice chooses the Button tool (=). Pressing it three times
chooses the Field tool (E3).

¢ Display the Message box. Type c and press Return. Repeat
the experiment, first typing the letter s and then typing the
letter b.

Typing c displays the Card Info dialog box, just as if you had chosen the
Card Info command from the Objects menu. The s message displays
the Stack Info dialog box, and the b message displays the Bkgnd Info
dialog box.

# Press Option-Tab once.

. Pressing Option-Tab opens the Tools palette. You can close it by pressing
Option-1ab again.
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- Chapter 7

Creating New Stacks

In this chapter you'll build one stack from start to finish and create
another one as well. In the process you'll review many of the other
techniques you've learned in this book.
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Startlng from scratch 1 ehis section you’ll create a stack from scratch.

Designing the stack  The first step in creating a new stack is to design it. Start by
thinking about who the stack is for and what the stack should do.
For example, suppose you wanted to make an electronic memory
book with interesting facts about your friends.

Your stack should be simple to use and easy to read. After thinking
for a while, you sketch out this design:

Background art. Fields. You need

should look lik <" room for the titl
notebook to ma Wm_ of the stack, anb
the stack easier . your friend’s name,

to understand.

A few simple ones will do.

< Note: If you want to create professional-looking stacks,
you should design them carefully. You may want to read @
Apple’s HyperCard Stack Design Guidelines, published by
Addison-Wesley. <
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Starting a new stack  The first step is to create a new stack, as described in this exercise.

Getting ready: If you’ve set your user level to Authoring or
Scripting, start now with step 1. Otherwise, increase your user level

as described in “The User Preferences Card” in Chapter 4.
1. Go Home.
2. Choose New Stack from the File menu.

The New Stack dialog box appears, as shown in step 4.
3. Make sure you're in the Stacks folder.

4. Name the stack and choose your options as shown here:

Make sure £2:HD:HyperCard:Stacks:

you're in the 3972 free of 20860 K. ( Volumes )
Stacks folder. L% Rddresses &] (TWew Folder )
£ Breideas I m
£ Birds Do )
£ Buttonldess (_Doea
{4 fulender

L% Toontditer inallv. click

Type Friends || New Stack Name: € Create Finally, click Create.
N\
N Friends | C Tancel )
Make sure this box T Copy Current Background

is not checked.

The new stack opens, absolutely blank.

Copying the background art  The background art for this stack is supposed to look like a spiral
8 notebook. You could use the Paint tools to draw your own, but
instead, this exercise will have you copy the art from the Art
Ideas stack.

Getting ready: Make sure you’re in the Home stack.
1. Go to the Art Ideas stack.

Go Home, click the Tool Kit button at the bottom of the card,
and then click the Art Ideas button.
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2. Click the Background Art category.

This stack contains clip ort you
can copy into your own stacks.

L Click here.

3. Choose Background from the Edit menu.
You enter the background and the word Background appears @

the menu bar.
The artwork you want to copy is on the background.
4. Tear off the Tools menu.

Pull the menu down as if you were going to choose a command,
but keep dragging past the bottom. Place the Tools palette
wherever you like. (If you need more details, see “Tools of the

Trade” in Chapter 6.)

5. Double-click the Selection tool (:%) in the Tools palette to
select all the art.

A moving dashed line surrounds the card, indicating that the ari

is selected.
6. Choose Copy Picture from the Edit menu.
7. Return to your new stack by using the Open Stack command.

Choose Open Stack from the File menu and double-click the
name “Friends” to open the stack you’re working on.
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8. Choose Background from the Edit menu.

Confirm that you’re working in the background by making sure
the word Background is in the menu bar.

9. Choose Paste Picture from the Edit menu.

You’ve finished the background art.

COpying the In this section you'll put three buttons—Home, left arrow, and
background buttons  right arrow—in the background. You'll copy them from the
Addresses stack.

O The left arrow button
Start by copying the left arrow button.
Getting ready: You should have the Friends stack open.
1. Choose the Browse tool ().
2. Choose the Open Stack command from the File menu.
3. Double-click Addresses.
The Addresses stack opens.
4. Choose the Button tool (=) from the Tools menu.
5. Click the left arrow button once to select it.
® A moving dashed line surrounds the selected button.
6. Choose Copy Button from the Edit menu.
7. Open the Friends stack using the Open Stack command.

Choose the Open Stack command from the File menu and
double-click Friends.

8. Choose Background from the Edit menu.

Make sure you see the word Backgroundin the menu bar.
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9. Choose Paste Button from the Edit menu.

The button appears. You'll move it into place in a later exercise.

The right arrow button

Continue by copying the right arrow button from the Addresses
stack to the Friends stack.

Getting ready: Make sure you're still using the Button tool (=).
1. Open the Addresses stack.

Just as you did in the last exercise, choose Open Stack from the -

File menu and double-click Addresses.
2. Click the right arrow button once to select it. O
3. Choose Copy Button from the Edit menu.
4. Return to the Friends stack.

Choose the Open Stack command from the File menu and
double-click Friends.

5. Paste the button on the background.

Choose Background from the Edit menu and then choose Paste
Button from the Edit menu.

The Home button
Finally, copy the Home button. O
Getting ready: Make sure you're still using the Button tool (=).

1. Go back to the Addresses stack using the Open Stack

command.
2. Click the Home button once to select it.

3. Choose Copy Button from the Edit menu.
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Click here.

Return to the Friends stack using the Open Stack command.

. One last time, paste the button on the background.

Choose Background from the Edit menu and then choose Paste

Button from the Edit menu.

7. Click the Icon button.

Button Name: |ﬂm |
Bkgnd button number: 3  Bkgnd button ID: 3

Clhwkme — seyle

B<] Auto Hilite
Family: | 0 (none) |
[ Share Hilite !

(Link To...) ( Font...
[Script...] [Colors...] ( 0K ]] [Cuncel]

8. Change the icon.

ID: 1022 "Homey Home" from "HYPERCARD.I165"

SLH0 M M| e @ U
® ¢ 0 B oA\G D
SRR U C I | )
S 4 U Kol 5
(one ) (Cancel) [k 3

9. Finally, click OK in the Info dialog.
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Double-click the Home button to open its Info dialog box.

If necessary, use
the scroll bars to
find the small
Home icon.

Click the icon to
select it . . .

... then click OK.




Arranging the buttons
Now you need to move the buttons into position.

Getting ready: Make sure you're still viewing the Friends stack and
that you still have the Button tool (@) selected.

1. Make the Home button smaller.

Drag its corner to make the button just a little bigger than the
icon in its center.

2. Move the buttons into position:

Move the buttons
to these locations.
(Remember to
drag them by their
middles, not

their corners.)

Creating the  In this section you'll create the six background fields for your new
b’chkgI‘ ound fields stack. Three will be shared-text fields—a large one for the stack’s
title and two small ones for the labels “Hometown” and “Fun
Facts.” The other three fields are for your friend’s name, where
your friend lives, and some fun facts about your friend.

The stack’s title
In this exercise you'll create a shared-text field for the stack’s title.

Getting ready: Make sure you're still viewing the Friends stack and
working in the background.

1. Choose New Field from the Objects menu.

The new field appears in the middle of the window.
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2. Double-click the new field to open its Info dialog box.
3. Click the Shared Text check box to select it.

This option specifies that this field will have the same text on
every card.

4. Click the Font button and set the text style for the field as

follows:

Click 16.
........... Sty]e . 2 ) d h
chne | [T B G e
Clitalie | | belvetic click OK.
[J0utline Times
[ Shadow Venice Iy Iy

Line Height: Font Size:
The quick brown fox jumps over

5. Click the Colors button and choose the text color as follows:

The quick [TXRTEEE takes o running leap
pver the laozy dog.

Click blue . . .

Frame Text

TR

ki o
LT 1 ... then click OK.

6. Click OK again.
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Adjust the size of
the field and
place it here.

(Make sure the field
is tall enough for
one line of text.)

7. Resize the new field and move it into place:

'

Remember, to change the size of the field, drag its corners; to

move the field, drag it by its middle. )

Text for the Stack Title field

In this exercise, you’ll fill in the text for the stack’s title and draw a
line below it.

Getting ready: Make sure you're still viewing the Friends stack.
1. Choose the Browse tool.
2. Press the Tab key once to find the field.
The insertion point blinks in the field.
3. Type Friends
4. Lock the field. @

Choose the Field tool (E1) and double-click the field to open its
Info box. Then click the Lock Text button and click OK.

5. Choose Background from the Edit menu.

The text disappears while you work in the background.
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6. Choose the Line tool () from the Tools menu.

When you choose the Line tool, the pointer changes to a
crosshair.

7. Hold down the Shift key and draw a line to go under the title.

Since you can't see the title, you’ll have to estimate where the line
should go. It goes about an inch below the bottom of the spirals.
If you make a mistake, you can use the Eraser tool (&) to erase
the line or the Field tool (E2) to move the title.

% Tip: If you don't want to be forced to estimate where the line
should go, you can draw the line on the card layer—where you
can see the text—and then cut it and paste it onto the

9,

background layer.

i Hold down the Shift
su[ | keyanddragto
‘;11 k‘\ draw the line here.
[
; ,JJ@
| |

Holding down the Shift key while you drag makes it easier to
draw a horizontal line.

8. Choose the Browse tool () to see how it looks.

Your friend’s name
In this exercise you'll create the field for your friend’s name.

Getting ready: Make sure you're still viewing the Friends stack.
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1. Choose Background.

Make sure the word Background is in the menu bar.
2. Choose New Field from the Objects menu.

The new field appears.
3. Click the new field once to select it.

4. Choose Text Style from the Edit menu to open the Text Style

dialog box.
This is a shortcut for clicking the Font button in the Field Info
box.
5. Set the text style for the field as follows: P
Click 16.
Courier 8 |y T ...and then

Bold (£==J
E I:alic Geneva click OK.
[JUnderline feLuekice
[Joutline
[C1Shadow I

m Line Height: - FontSue
Thequ1ckbrownfoxJumpsover

6. Resize the new field and move it into place:

)

EERRGREEGARGEEREGEREES

’_—__l Adjust the size of
. ; l the field and place
|

| it here. (Make sure
the field is tall
enough for one

| line of text.)

122 Chapter 7: Creating New Stacks




The two labels

In this exercise you'll create the field for the Hometown label and
duplicate it to create the field for the Fun Facts label. In the next
exercise, you'll enter the text.

Getting ready: Make sure you're still viewing the Friends stack and
working in the background.

1. Choose New Field from the Objects menu.
2. Double-click the new field to open its Info dialog box.
3. Click the Shared Text check box to select it.

4, Click Colors and set the color as follows:

The quick [TETTRLYS takes a running leap
over the lazy dog.

Choose this color . . .

Frame

... then click OK.

5. Click OK to close the Field Info box.
‘ 6. Position the new field like this:

" [ 1

Place the field here. : Hi

|

u
|

1{1
|H
i

TR
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While holding
down the Shift and
Option keys . . .

... drag this field
straight down . ..

7. Duplicate the field, as described in the figure:

... until its copy is
in position here.

Text for the labels ®
Now enter text for the labels.
Getting ready: Make sure you're still viewing the Friends stack.
1. Choose the Browse tool ().
You need the Browse tool to enter text in fields.
2. Press the Tab key twice and type Hometown
3. Press the Tab key again and type Fun Facts
4. Lock the Hometown label field.

Choose the Field tool (1) and double-click the field to open its
Info box. Then click the Lock Text button and click OK. ‘

5. Repeat the process to lock the Fun Facts label field.

The Hometown and Fun Facts fields

In this exercise you'll create the fields for your friend’s hometown
and for fun facts about your friend.

Getting ready: Make sure you’re still viewing the Friends stack.
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1. Choose Background from the Edit menu.
Make sure the word Background is in the menu bar.
2. Choose New Field from the Objects menu.
The new field appears.
3. Double-click the new field to open its Info box.
4. Click Show Lines to select the option.

The Show Lines option draws lines in the field to make it easier
for the user to see where to type.

5. Click OK.

6. Resize the new field and move it into place:

1333535390353903930R0aa R

’;, [ iy Place the field here.
ﬁl!!!nl |

;=.

[[L

|

|

waa e D

7. Duplicate the field as shown here:

G CCECECECECCECECEEEEET  While holding

down the Shift and
Option keys . . .

| e =1
1 e L\‘\M . drzlg this field

| straight down until

the copy is in
position here.

i
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If you clone the field successfully but don’t get it in
quite the right place, delete the new field and try
again. You can delete a field by clicking it once and
pressing the Delete key.

8. Fxtend the new field to near the bottom of the card.

Ly BB g

I.l“{}i
| ] l\

‘i While holding the
| Shift key down, .

1
(

u ____________________________________________________ ] drag this corner of
| om == the field here.

9. Choose the Browse tool ().

Checking your work — You've completed the background and should be ready to start
using the stack. Before going on, do a quick check to make sure you
didn’t make any mistakes.

Getting ready: You should be viewing the Friends stack and have
the Browse tool () selected.

1. Does your card look like this? ®

]
(M

Friends

Hometown

Fun Facts
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You should have
six fields in the
background . . .

.. and three buttons.

ﬂ If your card doesn't look quite right, review the
£57 - sections on background art, background buttons,

B\ "\ and background fields in this chapter.

3
& (ig
!

. Choose Bkgnd Info from the Objects menu.

Your Info dialog box should look similar to this:

Bkgnd Name: | |
Bkgnd 1D: 2748, Shared by 3 cards.

Your ID number
may be different.

Contains 6 background fields.
Contains 3 background buttons.
[ICan't Delete

[I0on't Search ¥

(Script.) @lors...) ([ 0K B (Cuncel]

The six fields are for (1) the title of the stack, (2) your friend’s
name, (3) the label “Hometown,” (4) the Hometown field, (5)
the label “Fun Facts,” and (6) the Fun Facts field. The three

buttons are left arrow, right arrow, and Home.

If you have too few buttons or ﬁelds on the

_more hkely, acc1dentally“‘created them on the card
instead of the background. (If you choose the Card
~ Info command from the Objects menu and the
 dialog box lists any buttons or fields, that’s probably
what you did.) See “Moving the Button From the
Card to the Background” in Chapter 6 for a reminder
about how to move objects from the card to the
background.
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If you have too many fields, you probably duplicated
an extra copy. Choose the Field tool and click the
extra field to select it. Then press the Delete key to
deleteit. k

3. Click Cancel to close the Bkgnd Info dialog box.

Using the stack  You use the Friends stack just as you would use any other stack. In
this exercise you'll enter text for the cards.

1. Choose the Browse tool ().
2. Press Tab to start typing in the first field.

3. Type the name of one of your friends, for example: Jennifer
Lu

4. Press Tab to move to the next field and type where she lives,
for example: Nashville, Tennessee, USA

Dorn't worry if the lines disappear while you type. They’ll come
back when you’re done.

ﬂ If pressing the Tab key doesni't take you to the correct
¥

id,  field, you can instead use the mouse to click where

8 \d
®

¥\ you want to type.
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5. Press Tab again to move to the bottom field and type a
description of your friend:

Fun Facts Jennifer’s favorite sport is soccer. She plays halfback

6. Choose New Card from the Edit menu and fill in the fields
like this:

1833333335339333553335330
il friends  Marina Ivanovna Kutuzova
mﬂ Press Tab to move

il Hometown
between fields.

¢

Fun Facts

7. Click the arrow buttons to test them.

Startlng With AN You created the Friends stack from scratch with an absolutely blank

eXiSting bﬂCkngUﬂd baclfg,round. It’s useful to know how to build a stack from scratch,
O but it’s not always necessary to do so. For many stacks, you may be
able to take advantage of someone else’s work.

For example, suppose you wanted to create a report about some
neat cars. Instead of starting from scratch, you can use exactly the
same background, as illustrated by the exercises in this section.
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Creating the stack  To create the stack, you'll copy the Friends background using the
New Stack command.

Getting ready: Make sure you're viewing your completed Friends
stack.

1. Choose New Stack from the File menu.
2. Type Whiz.Cars
3. Click the “Copy Current Background” check box to select it.

<=53:HD:HyperCard:Stacks:
5163 free of 20860 K. (—Vo_l@
T RAdresses ‘
% fevtdeos Kew Folder
£ Birds | ( Bpen )
% Buttonidens (_Doen .
£ Dalendar S
% frionds
Click here and New Stack Name: ( Create )
make sure the box [Whiz.Cars| | (CConcel )
is checked. Copy Current Background

4. Click Create.

After you click the Create button, HyperCard creates the new
stack and opens it. You are now in the new stack.

/A Important: You can use the New Stack command to create new
stacks based on many, but not all, existing stacks. Some stacks have
scripts that stop working if they’re copied into a different stack. ~@

Changing the In this exercise you'll change the text for the stack’s title and the
shared-text fields ~ two labels.

Getting ready: Make sure you're viewing the new Whiz.Cars stack
and that you’re using the Browse tool (). (To check the name of
the stack, choose Stack Info from the Objects menu.)
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10.
11.
12.
13.

14.

. Choose the Field tool (2).

Double-click the field with the word “Friends” in it.
Its Info box opens.

Unlock the field.

Click the Lock Text button and click OK.

. Use the same method to unlock the other two fields.

Double-click the field with the word “Hometown” in it, click
Lock Text, and click OK. Then repeat for the field with the

words “Fun Facts” in it.

. Choose the Browse tool (¥").

Press the Tab key.

The stack’s title is highlighted.

Type cars

The old text disappears as soon as you start to type.

Press the Tab key twice to highlight the word “Hometown.”
Type Manufacturer

Press the Tab key once to highlight the words “Fun Facts.”
Type Description

Choose the Field tool (E3) again.

Lock the three fields.

For each field in turn, double-click the field, click the Lock Text
button, and click OK.

Choose the Browse tool (™).
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Using the stack  Fill out a card as described in this exercise:
1. Press Tab to start typing in the first field.
2. Type the name of the car: Tarantula Jumbo Van

3. Press Tab to move to each of the next two fields and fill in the
rest of the card like this:

Tarantula Jumbo Yan

Mammoth Motors

Other examples You can use the same background for many other stacks. Here are
some examples:

Watering

Description

How related Where found

Gifts received Life cycle
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FlﬂlShlng UD  Congratulations. You've now completed all the exercises in this
book. If you like, you can quit HyperCard and delete some of the
practice files you’ve created, then go to the Home stack and delete
any buttons you no longer want. You may also want to go to the
User Preferences card in the Home stack and change your user level.

There’s one more “Experts Only” section on the next page if you
want to learn some more shortcuts. The last chapter describes a few
more ways to enhance your stacks.

When you’re finished with this book, you can use the HyperCard
1IGS Reference or the HyperCard IIGs Help stacks to look up

information about specific tasks.
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v Oflly This section describes several advanced techniques. If you prefer to
skip them for now, move on to the next chapter.

& Choose the Field tool (&) inside the Friends stack. While
holding down the (% key, draw a rectangle by dragging the

mouse diagonally.

You've created a field the same size as the rectangle you drew. This
alternative to the New Field command allows you to specify the size and
location of the field at the same time you create it. (The same technique

works with the Button tool.)

Before going on, you should delete the new field by selecting it and
pressing the Delete key. Choose the Browse tool ($) when you re done.

& While still in the Friends stack, choose the Protect Stack
command from the File menu. Then click Can’t Modify Stack

and click OK.

There’s now a padlock at the right side of the menu bar. If you try to
change the stack in any way, you'll get a message telling you the stack is

protected.

Before going on, you should choose Protect Stack again and deselect Cant
Modify Stack to turn off the protection. By the way, be careful when you
use the password feature of the Protect command. If you forget the
password, there's no way to turn off the protection.
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, | o Chapter 8

Onward

You now know enough to look through other people’s stacks and

create your own. Where do you go from here?

This chapter tells you where you can get more readymade stacks. It
also describes how you can begin using art, sounds, and HyperTalk

scripts to enhance stacks you create yourself.
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Where to get stacks HyperCard stacks are available from many sources. They range
from simple but useful stacks by beginners like yourself to
sophisticated commercial products that come with their own
manuals. You may find some of these stacks useful in themselves;
others may give you ideas for your own stacks. To find out what’s
available, start with these sources:

» Your authorized Apple dealer and your favorite software store.

» Your local Apple IIGS user group. A user group can be a good
place to find free (or inexpensive) stacks and to meet HyperCard
enthusiasts who are willing to share and discuss stacks they have
made. See the preface of the HyperCard 1IGS Reference for more
information about user groups, or call Apple at 1-800-538-9696
to find a user group near you. [

»  On-line bulletin boards run by user groups or electronic
information services. If you have a modem, you can download
stacks from these electronic sources just by paying their service
charge and any telephone charge that may apply. (Some stacks
may be shareware, meaning that if you like the stack and
continue to use it, you are honor-bound to send the author
a small payment.)

A\ Important: Apple sells two HyperCard programs, one for the
Apple IIGs and one for the Macintosh® computer. The stacks are
not interchangeable. When you obtain new stacks, make sure you
get ones that will run on the Apple IIGs. & ®

136 Chapter 8: Onward




Art for your StaCkS As an easy alternative to creating art for your stacks from scratch,

you may want to take advantage of a scanner or collections of
clip art.

Scanners work much like photocopying machines, except that
instead of producing an image on a piece of paper, they produce
an image on your Apple IIGS that you can paste into a stack. (Be
careful of copyright infringement, though. Copyright laws apply
to material copied electronically as well as to material that’s

photocopied.)

Another alternative is to purchase c/ip art—electronic collections of
drawings that you can copy and use for your own purposes. You can

get clip art from any of the sources for HyperCard stacks listed
® earlier in this chapter.
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Sounds for  One of the most interesting ways to enhance a HyperCard stack

your stacks isto add sound. Imagine, for example, a vocabulary ﬁtack that
pronounced words. One way to incorporate sounds into your stacks
is to use a special recording device. Such devices can work with
microphones, or you can connect them directly to your home
stereo. As with visual images, however, copyright laws apply to
electronic recordings of sounds.

Another way you can add sounds to your stack is to learn the
HyperTalk commands that play sounds.

Scr lptlng The most powerful way to enhance your stacks is to learn
HyperTalk, the programming language that’s built into HyperCax.
With HyperTalk, you can write your own instructions, called scripss,
for HyperCard to carry out. Writing scripts is called scripting.

If you'd like to learn more about scripting with HyperTalk, you
should read the HyperTalk Beginner’s Guide.
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Using HyperCard
on a Network

I run HyperCard IIGS, you need a hard disk attached directly

to your computer or you need to be connected to a file server via a
network. The instructions in this book assume you have your own
hard disk. However, if you're using HyperCard on a file server, you
can still use this book, provided you follow the special instructions

in this Appendix.
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The network  Your network administrator must install HyperCard on the server

administrator’s before you can begin.

preparations Netwqu adm‘inistrat(?rs can install HyperCard on the server k?y
following the instructions in Chapter 2. After the installation is
complete, the administrator should modify the privileges for all the
HyperCard files and folders on the server so no one can make
changes to them.

Your pPr eparations You must have your own copy of any files that you want to change.

(If you only need to look at a file, you do nothave to have your own
copy of it.) ®

You'll change only two files as you go through this book: Home
and Birds. To save copies of them in your own directory, follow
these steps.

1. Launch HyperCard.

Double-click the HyperCard icon on the server. (See
instructions at the beginning of Chapter 3 for more details.)

Make sure you’re in the Home stack.
2. If HyperCard asks for your name, just click OK.
3. Choose the Save a Copy command from the File menu.
4. Choose an appropriate directory. P

You must choose a directory in which you have privileges to
make changes: either your own user area on the file server
or a 3.5-inch disk in your own computer. Your network
administrator can help you if you don’t know where to save

the files.
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. Type Home
Click Save.

Click the Birds button.
Choose the Save a Copy command from the File menu.

© ® N W

Type Birds
10. Click Save.
11. Choose Quit from the File menu.

® Changes to the Having made these preparations, you should be able to follow

instructions in thlS almost all of the instructions in the rest of the book without any
b()()k other changes. The exceptions are as follows:

= You don't have to install HyperCard yourself, so skip Chapter 2.

»  When you start creating your own files in Chapters 6 and 7, be
sure to save them in your own directory.

m  Whenever you see instructions about a specific directory, you
should be aware that your directories are somewhat different
from the ones described in the book. Except for the Home and
Birds files (and the files you create yourself), all the HyperCard

files are on the server.
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A background layer The layer behind the card
layer, containing all the elements of the
background. You see the elements of both
layers when you look at a card, as if the card
layer were a transparent layer in front of the
background layer.

application  See program.
application program  See program.

authoring Creating or modifying buttons, links,
fields, cards, backgrounds, and stacks using the |y -qwee To explore HyperCard stacks by clicking

B i i .
utton.tool, the Field tool, and commands in buttons and using the Go menu.
the Objects menu. Also refers to the user level

tha; allo(;vshyoglt)(.) use the Button tool, the Field  progge tool () The tool you use to click buttons
tool, and the Libjects ment. and to position the insertion point in fields.

button A rectangular “hot spot” on a card or

B% background that responds when you click it

background A template shared by a number of according to the instructions in its script. For
cards. Each card with the same background has example, clicking a right arrow button with the
the same pictures, fields, and buttons in its Browse tool can take you to the next card.
background layer.

Button tool (©) The tool you use to create, change,
and select buttons.
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C

card A rectangular area that can hold buttons, fields,
and graphics. All cards in a stack are the same
size. Each card is a composite of two layers—a
foreground layer, called the card layer, and a
background layer. You see the elements of both
layers when you look at a card, as if the card
layer were a transparent layer in front of the
background layer. Each layer can contain its
own buttons, fields, and graphics.

card layer The layer in front of the background
layer. You see the elements of both layers when
you look at a card, as if the card layer were a
transparent layer in front of the background
layer.

clipart Electronic pictures that you can copy from
one stack (or any other document) and paste
into another stack. The term comes from the
use of scissors to clip pictures on paper. Several
of the stacks that come with HyperCard include
clip art, and you can buy other clip art stacks
that contain many different types of graphics.

Cliph()’dl‘d The holding area in the computer’s
memory for what you last cut or copied.

Command-key (C3-key) equivalent The
combination of the (J key and another key on
the keyboard that you can press instead of
choosing a command from a menu.

D, E

download To transfer information from a distant
computer to your own computer; to transfer
files (such as HyperCard stacks) over telephone
lines from a distant computer to your own
computer with the aid of a modem.
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field A rectangular area in which you type field text
(as opposed to Paint text). Fields may exist in
either the card layer or the background layer.

field text Text that appears in a field created with the
Field tool or the New Field command. Field
text can be edited and searched, while Paint
text cannot.

Field tool (1) The tool you use to create, change,
and select fields.

H

Home cards The first five cards in the standard .
Home stack, designed to hold buttons that take
you to stacks, applications, and documents.
Choose Home from the Go menu (or press
(3-H) to get to the card in the standard Home
stack that you've seen most recently.

HyperTalk HyperCard’s built-in script language for
HyperCard users.

LJK

I-beam pointer The pointer used to enter and edit
text.

insertion point The location in a field where text ‘
will be added or deleted, represented by a
blinking vertical bar. You can position the
insertion point in a field by moving the I-beam
pointer over the location you want and clicking,

Glossary




L

link A short script, usually in a button, that allows
you to move immediately to a specific card in a
stack, to an application, or to a document. For
example, clicking a button that contains a link
to your Addresses stack takes you immediately
to the first card of that stack.

M,N, O

message A HyperTalk instruction sent to
HyperCard through a script or through the
Message box. Examples of HyperTalk messages
are help, go home, and the date.

MESsage box A special window in which you can
type messages and in which HyperCard can
type replies. To open or close the Message box,
choose Message from the Go menu.

P

Paint text Text you type using the Paint Text tool.
Paint text can appear anywhere, while field text
must appear in a field created with the Field
tool. When you finalize Paint text by clicking, it
becomes part of a card or background picture
and cannot be edited except by erasing it and
starting over. Unlike field text, Paint text cannot

' be searched.

Paint tools  Any of the HyperCard tools you use to
create graphics. The Paint tools are all the tools
below the top row in the Tools menu.

palette A small window that displays icons or
patterns you can select by clicking. You can see
two of HyperCard’s palettes, the Tools palette
and the Patterns palette, simply by “tearing oft”

their respective menus. See also tear-off menu.

picture  Any graphic or part of a graphic, created
with a Paint tool or imported from an external
file, that is part of a card or background.

pixel Short for “picture element”; the smallest dot
you can draw on the screen.

point In printing, the unit of measurement of the
height of a text character; one point is about %
of an inch. When you choose a font, you can
also choose a point size, such as 10-point, 12-
point, and so on.

program A file containing instructions that a
computer can follow to perform certain tasks.
HyperCard is a program. Computer programs
are collectively referred to as software, and are
sometimes called applications or application

p?’ Y anis.

R

Recent A special dialog box that holds pictorial
representations of the last 18 unique cards
viewed. Choose Recent from the Go menu to

get the dialog box.

S

scanner Any graphic input device that converts
printed matter into bit (digital) data.

script A collection of instructions written in
HyperTalk, often associated with a button.
You use the script editor to add to and revise
a script.

script editor A large window in which you can type
and edit a script.
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scripting  The act of writing scripts; writing Tools palette  The palette that you can get by
programs in HyperTalk. Also refers to the user “tearing off” the Tools menu.
level that allows you to look at and change
objects’ scripts.

UVWXY,Z

user level A HyperCard setting that determines
which of HyperCard’s capabilities are available.
You can set the user level on the User
Preferences card in the Home stack. Each
user level makes all the options from the lower
levels available, and also gives you additional
capabilities. The five user levels are: Browsing,
Typing, Painting, Authoring, and Scripting. You
may also limit the user level for a particular stack
by using the Protect Stack command.

shared text  Field text that appears on every card in a
background. Text in shared-text fields cannot be
searched.

shareware Software you can copy and try before
sending payment to the author.

stack A HyperCard document. Every stack consists
of one or more cards.

T

User Preferences card The last card in the Home

tear-off menu A menu that you can remove from stack, where you can set your user level and
the menu bar by dragging the pointer beyond select or deselect the Blind Typing, Power Keys,
the menu’s edge. HyperCard has three menus and Arrow Keys options.

that can be torn off: the pictorial Go menu, the
Tools menu, and the Patterns menu. When torn
off, these menus are called palettes.
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A
adding art 52-56
adding buttons
to Home stack 87-88
linked to Calendar stack 88-93
adding cards to stacks 38-40
adding sounds to stacks 138
adding text to cards 34-36
Addresses stack 69-70
arranging buttons 106
arrow buttons
changing style of 87-88
copying to background of new stack 115-116

arrqw keys
aving through stack with 31
typing and 34, 36
arrow pointer 23
art. See Art Ideas stack; graphics
Art Ideas stack 52
copying background from 113-115
authoring 73-109
adding new button to Home stack 77-78
backgrounds 79-84
backup copies and 76-77
buttons 85-96

fields 96-105
preparations for 76-78
tools needed for 74-75

B
Back command (Go menu) 28-29
background 79-84
adding a new field to 101-103
card compared with 79, 81-84
copying to new stack 130
creating for new stack 112-128
deleting a field in 97
examining 79-81
existing, creating stacks from 129-132
spray painting 83-84
Background command (Edit menu) 80-81
copying background art with 114, 115
copying buttons with 95, 115, 117
for decorative touches 106-108
moving a button with 93
background fields, copying 124
background layer 84

backup copies 64
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Bkgnd Info dialog box 81
checking copied fields in 127-128
shortcut for displaying 109
blank stack, creating 113
Browse tool 23
copying a button with 94
disabled 46
keyboard shortcut for 82
selecting from Tools menu 46, 56
testing a new button with 92
testing a new field with 101
browsing
with arrow buttons 25-26
with arrow keys 31
in cards 25-26
with Go menu 27-30
in HyperCard Tour 18-21
opening files 22-24
quitting 30
in stacks 17-31
tricks and shortcuts for 31
bulletin boards, downloading stacks from 136
button(s) 9
adding
to background of new stack 115-118
by copying 93-96, 115-118
to Home stack 77-78
arranging on new background 117
assigning an icon to 89
background, copying 115-118
changing 85-96
changing icon for 117
changing size of 90
changing style of 87-88
copying 93-96, 115-118
creating 88-90
deleting 78, 85
hidden 66-67
in Addresses stack 70
finding 66-67
icons for 65
assigning 89

light bulb 64-65

linking to stacks 90-92

locating 6667

moving 86-87, 90, 106

from card to background 93

opening stacks with 22-23

positioning 118

readymade 93

resizing 90

script of 87

shortcut for displaying 109

testing 92, 93
Button Ideas stack, copying a button from 93-96
Button Info dialog box 87

changing button style with 87-88

changing icon with 117 ‘

creating link with 90-91

creating new button with 88-89
button script, shortcut for displaying 109
Button tool 85

changing button style with 87

copying buttons with 94, 115

creating a link with 90-91

moving a button with 93

shortcut for choosing 109
buying readymade stacks 136

C
calculations, in Message box 49
Calendar stack
adding a button linked to 88-93 ’
linking button to 88-93
Can't Modify Stack option 134
card(s)
adding pictures to 52-56
adding to stack 3840
adding text to 34-36
backgrounds compared with 79, 81-84
browsing through 25-26
arrow keys for 31
with Go menu 27-30
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card(s) (continued)
common elements in. See background
definition of 4
editing text on 36-38
entering text on 34-36
first, going to 28
last, going to 28
moving backward through 25-26, 28-29
with arrow keys 31
with Prev command 28
moving forward through 25
with arrow keys 31
with Next command 27
new 38-40
printing 56-57
itrlrning to, with Back command 28-29
ching for text on 49-51
spray painting 81-82
typing on 34-36
card file, HyperCard as 4, 26
Card Info dialog box, shortcut for displaying 109
card layer 84
card number, deleting field for 97-98
changes to HyperCard files, saving 18, 4041
changing
all cards. See background
arrow buttons 87-88
button icon 117
button(s) 85-96
appearance and style 87-88
size 90, 118
‘ld(s) 96-105
attributes 97-99
Home button 87-88
HyperCard files 18, 4041
shape, dragging rule for 100
text 36-38
circular card file, HyperCard as 4, 26
clip art 52-54, 137. See also graphics
Clipboard 37
closing
Help stack 61

Message box 47
stacks, by opening new one 23
Tools palette 75
color of field, changing 97-99
Colors button 98
color sets, background colors and 79

copies, backup 64, 76-77

Copy Button command (Edit menu) 94, 115, 116

copying
background art 113-115
backgrounds, to new stack 130
buttons 93-96, 115-118
fields 103-105, 124
pictures 52-54, 113-115
stacks 64, 76-77
Copy Picture command (Edit menu) 54, 114
correcting typing mistakes 36, 48
Create QuickLink Button 77
creating
background for new stack 112-128
buttons 88-90
fields 101-103, 118-126
by drawing a rectangle 134
labels for fields 103-105, 118-126
links 90-92
stacks 6, 111-134
from existing background 129-132
from scratch 112-129
cursor. See pointer
Cut Button command (Edit menu) 93
Cut Text command (Edit menu) 37

D
date, in Message box 48

Delete key, going to top of field with 35. See also
deleting
deleting
buttons 78, 85
fields 97-98
designing a stack 112
disk drive. See hard disk

Index

149




dragging

general rule about 100

Shift and Option keys with 103-104
drawing a new field 134
duplicating. See copying

E
editing text 36-38
Edit menu commands
Background 80-81
copying background art with 114, 115
copying buttons with 95, 115, 117
for decorative touches 106-108
moving a button with 93
Copy Button 94, 115, 116
Copy Picture 54, 114
Cut Button 93
Cut Text 37
New Card 38
Paste Button 93, 95, 116, 117
Paste Picture 55-56, 115
Paste Text 37-38
emergency exits 68
entering text on cards 34-36
Eraser tool 82
Exit Help button 61
exiting
Help stack 61
HyperCard 30
stacks 68
exploring 63-72
Addresses stack 69-70
backup copies and 64
emergency exits while 68
Picture Puzzler stack 71-72

F

field(s) 9, 34
background, creating 118-126
changing 96-105
changing attributes of 97-99

copying 103-105, 124
creating 101-103, 118-128
checking after 127-128
by drawing a rectangle 134
creating labels for 103-105
deleting 97-98
entering text in 34-36
on new card 3940
finding 67
font in, changing 97-99
I-beam pointer in 35
labels 123-124
modifying 97-99
moving between 40, 62
moving closer together 99-101
naming 104
placing insertion point in 35 .
printing 57
resizing 99-101, 104
selecting 67
shared text 104
changing 130-131
creating 118-126
typing text into 105
stack title 118-122
unlocking 131
Field Info dialog box
changing field attributes in 98
creating a new field with 101
creating title field with 119
locking shared text with 105
Field tool 96-105 ‘
copying a field with 103
entering shared text with 105
keyboard shortcut for 109
File menu commands
New Stack 113
copying a background with 130
Open Stack 24
copying background art with 114
copying background buttons with 115, 116, 117
keyboard shortcut for 24
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File menu commands (continued)

Print, for printing whole stack 57

Print Card 57

Protect Stack 134

Quit HyperCard 30

Save a Copy 8, 41, 76-77

canceling 41

files, saving changes to 18, 40—41. See also stacks
file server, using HyperCard on 139-141
Find button 60

copying 93-96
Find command (Go menu) 46, 49-51

keyboard shortcut for 51
| for pasting a picture 55
~ finding text 49-51

Fiﬁl‘opie feature, in HyperCard Help stack 60-61
Firommand (Go menu) 28
Flip Horizontal command (Paint menu) 108
floppy disk, locking 13-14
folder, for HyperCard. See New HyperCard Folder
Font button 98

G

going Home, keyboard shortcut for 68
Go menu, alternative 62
Go menu commands 27-30
Back 28-29
pasting a button with 95
Find 46, 49-51
keyboard shortcut for 51
for pasting a picture 55
st 28
Help 58, 68
keyboard shortcut for 58
Home 28, 29, 68
keyboard shortcut for 31, 68
Last 28
Message. See Message box
Next 27
Prev 28
Recent 29-30

graphics
on alternative Go menu 62
in Art Ideas stack 113-115
clip art 52-54, 137
copying 52-54, 113-115
deselecting 56
disappearing from card 54
drawing line under stack title 120-121
flipping 108
for new stack 113-115
pasting 54-56
positioning 56
scanning 137
sources for 137

H
hard disk, installing HyperCard on 13-16
hardware
for network 139
for running HyperCard 12
Help command (Go menu) 58, 61
Help stack 58-61
closing 61
exiting 61
searching in 60-61
using list of topics in 58-61
hidden buttons
in Addresses stack 70
finding 6667
Home button 23
changing style of 88
copying 117
to background of new stack 116-117
moving 86-87, 118
resizing 118
Home cards 4144
Create QuickLink button on 77
first 19, 42
returning to 44
renaming 4344
Home command (Go menu) 28, 29, 68
keyboard shortcut for 31, 68
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Home stack 41-46

adding a button to 77-78

creating a link to 91

Home cards in 41-44

opening with Home button 23

returning to 23, 28, 29, 68

User Preferences card in 44—46
HyperCard

installing 11-16

main parts of 9

opening 18

quitting 30

requirements for running 12

similarity to other software 7-8

uses for 3-5

using on a network 139-141
HyperCard disks 13

locking 13-14
HyperCard files. See stacks
HyperCard Help button 58
HyperCard Help stack. See Help stack
HyperCard.IIGS folder, renaming 18
HyperCard Stack Design Guidelines 112
HyperCard Tour 18-21
HyperTalk 6,49, 138
HyperTalk Beginners Guide 6, 49, 138

L]

I-beam pointer 23, 35
Icon button, changing icon with 117
icons 65
assigning to buttons 89
insertion point 35
using Tab key to place 40
Installer program 13, 14-16
Installer Script, on HyperCard Program disk 15-16
installing HyperCard 11-16
on a network 140

invisible buttons, finding 66-67

K

keyboard commands. See shortcut(s)

L

labels
creating 103-105, 123-124
typing text for 124

Lasso tool 53

Last command (Go menu) 28

light bulb button 64-65
deleting 85

Line tool, 121

link, creating 90-92

LinkTo button 91

locating text 49-51

Lock Text box 105 '

Lock Text button
unlocking a field with 131

M

“marching ants” 53, 85
memory requirements, for running HyperCard 12
menu bar

showing and hiding 68

tearing Tools menu off 74
menus. See specific menus
Message box 4649

Find command and 46, 49-51

moving 46
Message command (Go menu). See Message Box
modifying a field 97-99
moving

around in stacks 25-30, 31

buttons 86-87, 90, 106, 117

from card to background 93

dragging rule for 100

fields closer together 99-101

Message box 46
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moving (continued)
through cards,
backward 25-26, 28-29, 29-30, 31
forward 25, 27, 31
through fields 40
backward 62
forward 62
music, adding to stacks 138

N
network, using HyperCard on 139-141
New Card command (Edit menu) 38
New Field command (Objects menu) 101, 122, 123,
125
%rnative to 134
title field 118

New Stack command (File menu) 113

copying a background with 130

Next command (Go menu) 27
Notes field, creating 101-103

O
Objects menu commands
Bkgnd Info 81
Button Info 87
Field Info 98
New Button 88
New Field 101, 122, 123, 125
alternative to 134
for title field 118
o g
files 22-24
HyperCard 7, 18
stacks 22-24
with buttons 22-23
with Open Stack command 24
Open Stack command (File menu) 24
copying background art with 114
copying background buttons with 115, 116, 117
Option key

displaying a button script with 109
dragging a field with 103-104
Option-Tab keys, opening or closing Tools palette
with 109

P
Paint Bucket tool 106-108
painting, spray. See Spray painting
Paint menu, Flip Horizontal command 108
Paint tools 9
palette, Tools 74-75
password warning, for Protect Stack command 134
Paste Button command (Edit menu) 93, 95,116, 117
Paste Picture command (Edit menu) 55-56, 115
Paste Text command (Edit menu) 37-38
pasting pictures 54-56
Patterns menu, for decorative touches 107
Picture Puzzler stack 71-72
pictures. See graphics
pointer(s) 23

arrow 23

Browse tool 23

disabled 46
selecting from Tools menu 46

I-beam 23, 37
Preferences card. See User Preferences card
Prev command (Go menu) 28
Print Card command (File menu) 57
Print command (File menu) 57
printing 56-57
programming language (HyperTalk) 6, 49, 138
Protect Stack command (File menu) 134
puzzle. See Picture Puzzler stack

Q

Quit HyperCard command 30
quitting

Help stack 61

HyperCard 30

stacks 68
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R

RAM requirements, for running HyperCard 12
readymade stacks 136
Recent command (Go menu) 29-30
Rectangle tool 106-108
renaming Home cards 43-44
repositioning a graphic 108
resizing

buttons 117

fields 99-101, 104
retracing your steps

with Back command 28-29

with Recent command 29-30

S
Save a Copy command 8, 41, 76-77
saving, automatic 36
saving stacks 40—41
scanned art 137
script of button 87
shortcut for displaying 109
scripting 138
Scripting level 4546
scripts 138
Search button 60
copying 93-96
Search feature, in HyperCard Help stack 60-61
selecting fields 67
Selection tool
copying background art with 114
flipping a picture with 108
shadow box, on HyperCard tour 20
shadow button, changing to transparent 87-88
shared text field 104
changing 130-131
creating 118-126
typing text into 105
shareware 136
Shift key
dragging a field with 103

drawing horizontal line with 121

moving a field with 98, 99
Shift-Tab, moving backward through fields with 62
shortcut(s)

for alternative Go menu 62

arrows keys for navigation 31

for Background command 80

for Browse tool 82

for browsing through stacks 31

for Card Info dialog box 109

for choosing Button tool 109

for choosing Field tool 109

for choosing a tool 109

for Cut Text command 37

for displaying button script 109

for displaying dialog boxes 109

for Find command 52

for Help command 58 .

for Home command 31, 68

for Open Stack command 24

for Paste command 37
size changes

for buttons 118

for fields 99-101, 104
software, system, for running HyperCard 12, 14
sound

adding to stack 138

invisible button for 66-67
spray painting 81-84

a background 83-84

acard 90-92
Spray tool 81, 83

stack(s)
art for 52-56 ‘

sources of 137
authoring 73-109
adding new button to Home stack 77-78
backgrounds 79-84
backup copies and 76-77
buttons 85-96
fields 96-105
preparations for 76-78
tools for 74-75
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stack(s) (continued)
blank 113
browsing through 17-31
with arrow buttons 25-26
with arrow keys 31
with Go menu 27-30
opening files 22-24
quitting 30
tricks and shortcuts for 31
commercial 136
copying 64, 7677
creating 6, 111-134
from existing background 129-132
from scratch 112-129
definition of 4
igning 112
wnloading 136
exploring 63-72
finding cards in 49-51
finishing touches for 106-108
Go menu for browsing through 27-30
looking at cards in 25-26
moving around in 25-30
arrows keys for 31
with Go menu 27-30
opening 22-24
with buttons 22-23
with Open Stack command 24
printing 57
protecting 134
readymade 136
acing steps through
with Back command 28-29
with Recent command 29-30
saving 4041
sounds for 138
sources for 136
tinkering with 73-109. See also authoring
Stack Info dialog box, shortcut for displaying 109
Stack Title field
creating 118-120
entering text in 120-121

Style menu
chagning button style with 88
creating a field with 101
creating a label with 104
system software, for running HyperCard 12

T
Tab key
choosing Button or Field tool with 109
moving forward through fields with 62
selecting fields with 67
tabs, and typing on cards 34
“tearing off” Tools menu 74
testing a linked button 92, 93
testing a new field 102-103
text
automatic saving of 36, 4041
correcting 36
entering in new stacks 128-129
for labels 124
searching for 49-51
shared field, changing 130-131
Text Style dialog box, changing text attributes in 98
title field
changing text in 130-131
creating 118-120
entering text in 120-122
Tools menu
shortcuts to tools on 109
tearing off 74
Tools palette 74-75
opening or closing, shortcut for 109
selecting all art in 114
Tour, HyperCard 18-21
transparent button, changing from shadow 87-88
typing on cards 34-38
correcting mistakes 36
problems with, and disabled Browse tool 46
Typing level 44
typing in Message box 48, 49
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UV
unlocking a field 131
user groups, stacks from 136
user level

Scripting 45-46

selecting 4446

Typing 44
User Preferences card 41, 44—46

W. XY, Z
windows, HyperCard vs. other software 8
word wrap, automatic 36
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